[semi-rant] AppleScript Studio, hothouse flower

in Genius Bar edited January 2014
So I finally have a reason to build an AppleScript application, to build a GUI that interacts with Snak to send and receive messages via chat.

I start with the Hello World tutorial just to get used to the environment. Start the project, try to save it as the docs advise and find out that the option to save is greyed out (that should have been my first warning). Double-click MainMenu.nib to launch IB, drag the button on to the window, open the Inspector, search for the Applescript option in the popup menu.

Not there.

Search around on apple.com. Find one post with someone who had the same problem. One person says, well, you have to save first. No response. I can't save first, so I try to modify something anyway before double-clicking the NIB file, just to force a save. Doesn't make a difference. No love from IB.

Search around on google. Find the MacScripter.net forums. Another person had the same problem. There's some back and forth, and the original poster finally posts that he's solved it by reinstalling 10.3, updating to 10.3.5, and then doing a fresh install of Xcode. I try blowing away my /Developer tree and reinstalling Xcode fresh. Nope. So I'm stymied right at the beginning of the most basic tutorial, and never mind what I had hoped to accomplish!

I can do a fresh install of Panther, but I have far better uses for my time than doing an operating system reinstall so that IB can recognize when it's working on a NIB from an AppleScript Studio app.

The take-home message is that AS Studio in Xcode 1.5 is absurdly brittle. There is, of course, no acknowledgment of any of this in the documentation, which predates 1.5.

Has anyone here run into this? Anyone solved it by means of something less radical than an OS reinstall? Is there something really, really obvious that I'm just not seeing? I've tried every permutation I can think of to convince IB to do the right thing, and it never fails to bring up the same Inspector options that it would for a button in a generic Cocoa app.


Thanks in advance.


  • Reply 1 of 1
    amorphamorph Posts: 7,112member
    For the record, a fresh archive and install of Panther, followed by a totally fresh install of the Developer Tools, followed by the creation of a project in a pristine new user account, finally got the AppleScript pane to appear in Interface Builder.

    Ludicrous, but at least I can get beyond Hello World now.
Sign In or Register to comment.