iTunes Installing Woes

Posted:
in Genius Bar edited January 2014
OK, I did something odd and deleted the iTunes.app (don't ask) in a unusal fit of cleanlieness I emptied the trash before noticing that I had dumped iTunes. No problem I though, just download it from the Apple site and away I go...



However, the mpkg installer is not letting me install it. It gets as far as selecting a destination, tells me "Installing this software requires 0 bytes of space", I click on next and all of the packages are greyed out and the "Action" for all of them is set to "Disabled" I looked in the installer logs but it doesnt show any errors and I dont really understand the rest of what it is telling me:



Mar 14 13:43:07 : === Starting check on volume /

Mar 14 13:43:07 : Requirement: requires "certain file content criteria" PASS for root=/, domain=0

Mar 14 13:43:08 : Selected volume 'Macintosh HD'

Mar 14 13:43:08 : Mounted at: /

Mar 14 13:43:08 : OpenFirmware: pci2/[email protected]/@0:9

Mar 14 13:43:08 : Partition type: Journaled HFS+

Mar 14 13:43:08 : Partition map: disk0s9

Mar 14 13:43:08 : Partition: 9

Mar 14 13:43:08 : Protocol: ATA

Mar 14 13:43:08 : Media Type: Generic

Mar 14 13:43:08 : Volume Size: 80018485248



Anyone got a clue for me?



edit: After reading the FAQ, I also deleted the cache as well, but with no change in symtoms.

Comments

  • Reply 1 of 3
    OK, fixed it. I checked the iTunes support forum on the Apple site, where thay had the following advice:



    1. Use the Finder window and type 'iTunes' without quotes in the top right search box and from the resulting search select 'iTunes4.pkg' parent=receipts and put in the trash... check also for 'iTunes.pkg' parent=receipts and if present put in trash...



    2. Check/fix the filesystem... use 'disk utility' on original install CD or DVD disk to repair Hard Disk... insert disk and restart computer holding down 'c' key. when installer appears, do not continue. Use 'Disk utility' from top menu. select your HD volume that has OS X on, select '1st aid' then 'repair disk'... if repairs are made run it again until no repairs are done, then verify... quit from top menu... return to the finder level.



    3. When back at Finder level.... Repair permissions ... go 'disk utility' from appl.>utilities... select HD on left ... select '1st aid'... 'repair permissions'.... if repairs are made run again until no repairs are needed... do not worry about messages "we are using special permissions etc. " that is OK... quit



    4. Download and install iTunes 4.7.1 from here...

    http://www.apple.com/support/downloads/itunes471.html



    5. Important... do steps 2 & 3 again



    6. Drag the iTunes Icon from the dock and let it go so it disappears... then go to the Applications folder and drag the new iTunes Icon to the dock and start from there...





    Worked like a charm.



    Do I get special kudos for answering my own question, or does it just make me a muppet for not checking the Apple site first?
  • Reply 2 of 3
    I am glad you got that solved!!! Mac wouldn't be the same without iTunes
  • Reply 3 of 3
    vox barbaravox barbara Posts: 2,021member
    Quote:

    Originally posted by slyinthedam

    ...

    Do I get special kudos for answering my own question, or does it just make me a muppet for not checking the Apple site first?






    a physical problem alone may be exciting to watch but won't emotionally involve us in the story. yours did. heck, next...
Sign In or Register to comment.