iPhoto 5 disaster

in iPod + iTunes + AppleTV edited January 2014
I recently attempted to install iphoto 5. All was going well until the upgraded iphoto went to load the photos. The photos never loaded. Just a spinning timer/not colored ball. I let it run for a while as there are greater than 5000 pics in this library. Suspecting a crash, I quit the program and then restarted iphoto. Now all my thumbs are grey and the program doesn't see any of the pictures in the pictures library. I suspect there was a corrupt file in the library that made it crash. The pictures are still in the library. iPhoto just can't find them. I tried to rebuild the library-the program said something was locked and I couldn't do it. I tried to repair permissions-no change. I ran disk utility-no change. I threw the application out, threw the thumb....data,thumb...jpg and also the com.apple....iphoto, threw them away, restarted the computer and still had the same result-greater than 500 grey thumbs that couldn't find my pictures. I can't wait for tiger so I can do a clean install of the whole computer. How do I get me pics back it the meantime? I am at the point where I am ready to re-import all of them into a fresh iphoto. Is there an easy way to do this from the existing library? Should I back up the library to dvd(s) and then try to reimport them into a fresh iphoto???? Sorry for the long windedness...imac 15 800mhz,768ram,10.3.8,superdrive


  • Reply 1 of 4
    ipodandimacipodandimac Posts: 3,273member
    you need to be patient with it. 5000+ pics on a 800mhz machine wont be happening quickly.
  • Reply 2 of 4
    I waited over 3 hours. By the way, sorry for posting this in the wrong forum. Frustration has overtaken all processes.
  • Reply 3 of 4
    ipodandimacipodandimac Posts: 3,273member
    for the time being, navigate to your "Pictures" folder in Finder and back up that whole folder on a dvd or lots of cds. that is where iphoto stores pics and you can be sure that they wont be lost forever.
  • Reply 4 of 4
    hirohiro Posts: 2,663member
    Don't fret. Yes, this problem is related to an innocuously corrupted iPhoto4 library.

    Back up the pictures folder to somewhere safe. Either duplicate and then move, or just copy to another drive. Yes it takes a little space, but it feels better and you can get the space back when you're done.

    Re-install iPhoto4. Rebuild the library. You should get a dialog and see it start to work. It may take 20-30 minutes if it works, but not 3 hours.

    When everything works again in iPhoto4, back up the good library (you can delete the corrupt back up). Reinstall iPhoto5. It should update the library fine this time in the same 20-30 minute timeframe. If you want to be real safe back up the updated library. You're in business.
Sign In or Register to comment.