Firewire HD just quits!

Posted:
in Genius Bar edited January 2014
I've been using an external FW HD (Lacie D2) on an old G4 (733) and its been fine.



In the last couple of days though, its taken to quiting whilst in use.



The drive power cuts and there's a message about not having been quit correctly. If I take out the FW or power cable, it re mounts and works fine again for another hour or two, Then it happens again.



Any ideas...its driving me

Comments

  • Reply 1 of 6
    neutrino23neutrino23 Posts: 1,546member
    The drive power quits as in the light goes off and the drive spins down? Sounds like a problem with the power supply. Get in touch with La Cie. Possibly there is a heat related issue with the supply that causes it to shut down. You could try putting a fan on it. Use a hair dryer set to cold just to test it.



    Possibly the cable in from the mains is failing.
  • Reply 2 of 6
    zarathustrazarathustra Posts: 264member
    Seems unlikely its heat. The drive was on and working non stop for about 6 weeks running fine, its on a shelf on its own away from other heat sources, now it can't manage more than a couple of hours.



    The power lead seemed more likely, except that I have swapped it for another one (for an ext DVD drive) and the same thing happens.



    I have 'upgraded' through to 10.3.9 recently. Have Apple screwed-up Firewire I wonder?
  • Reply 3 of 6
    neutrino23neutrino23 Posts: 1,546member
    Regarding the heat issue, what I meant was that something may have failed internally (fan, capacitor became leaky) that causes it to now be developing heat faults whereas before it didn't.



    Do the lights actually go off? If the power light goes off I would think that rules out a software problem. It would be the same as pulling the plug. OS X would complain that the drive had been removed without properly unmounting it.
  • Reply 4 of 6
    messiahmessiah Posts: 1,689member
    Apologies if I'm pointing out the obvious here, but drive will heat up as you use it.



    If you have a drive sitting idling, and you're only transfering the odd file back and forth, it'll stay relatively cool. But if you are constantly working the drive, throwing huge amounts of data back and forth, that same drive is going to get very hot, very quickly.



    You aren't working the drive harder when it quits are you?
  • Reply 5 of 6
    messiahmessiah Posts: 1,689member
    If it's a S.M.A.R.T. drive mechanism, it'll cut-out automatically to protect itself.
  • Reply 6 of 6
    zarathustrazarathustra Posts: 264member
    I honestly don't think its a heat/use problem. the drive has worked for long periods of time (transferring small quantities of data back and forth for up six continuous weeks). My usage hasn't changed.



    Another thing, and my problem is kind of solved, albeit I don't know what happened or whether it'll happen again...



    I changed the Firewire port that I was connected to on the back of the Mac. This seems to have solved the problem - no more cut outs (PSU, cables, location of drive and usage same as before).



    That's good but why did it happen?



    My connections hadn't changed since I first connected the drive and the setup was working great.



    Can a port develop a malfunction that would cause this?



    I suspect a software issue but don't know how to find out.
Sign In or Register to comment.