MacNN reports... "new" Netscape

Posted:
in Mac Software edited January 2014
Download it at <a href="ftp://ftp6.netscape.com/pub/communicator/english/4.79/mac/complete_install/Comm4.79_Complete_US.bin"; target="_blank">ftp://ftp6.netscape.com/pub/communicator/english/4.79/mac/complete_install/Comm4.79_Complete_US.bin</a>;



Apparently, Netscape programmers realized that later versions have become bloated. So, now they can update the old version without worrying about people complaining about dropped features. I'm on IE, myself.

Comments

  • Reply 1 of 3
    xoolxool Posts: 2,460member
    Netscape 4 is so passé...
  • Reply 2 of 3
    addisonaddison Posts: 1,185member
    A lot of organisations like banks will allow connection using 4.7 but not 6. Aparently they are not happy with the security aspects of the newer browser.
  • Reply 3 of 3
    murbotmurbot Posts: 5,261member
    Ugh, I can't imagine ever using Netscape! I use IE, and it does piss me off now and then, but Netscape is such a slow pig. I can't imagine why anyone would want to use it.



    [ 11-18-2001: Message edited by: murbot ]</p>
Sign In or Register to comment.