New 2.3GHz G5 Tower Hard Drive Issue?

Posted:
in Genius Bar edited January 2014
Hi all. I was setting up a new dual 2.3GHz Tower today with 1GB memory, a Sony SuperDrive, and a Western Digital 250GB hard drive. After transferring the user stuff to the new Mac with the Migration Assistant, and running Software Update to bring everything up to spec, I ran Disk Utility to Repair Permissions (all OK), Disk Warrior 3.0.3 to check the file structure (all OK), and iDefrag 1.1b1 from Coriolis-Systems (a new app to replace Norton's venerable Speed Disk).



About 50 minutes into the defrag, iDefrag stalled. I was running the Mac from my FireLite FireWire drive (running MacOS X 10.4.1), and everything else seemed to be fine, so I was a bit puzzled. I've been using iDefrag for a couple of months now, and it has worked reliably for me. I entered into an email exchange with their support staff and they were puzzled as well. They suggested that I track issues being recorded in the system.log, as well as their own log, so I did.



It turns out that whenever iDefrag stalled, a few seconds later the system.log recorded this entry: kernel[0]: IOATAController device blocking bus error, and proceeded to continue to post a new entry every few seconds until I rebooted the Mac.



I had initially thought there might be a bad block on the hard drive, and had run a lengthy surface scan on the platters using Tech Tool Pro 4.0.4, but nothing turned up. A check of the volume's directory and file structure also reported no errors. So, I proceeded to repeatedly reboot and continue with iDefrag (three times as it turns out) since it was making progress (i.e., not hanging at the same place on the platter). iDefrag eventually successfully completed the defrag with no errors, so I'm now very suspicious about the hard drive.



This evening Coriolis Systems got back to me to say they saw some hard drive issues being reported with this log entry from last year, and sure enough there are. Those postings (search on IOATAController in Google) mostly applied to Mac laptops, but some users were reporting the issue with Western Digital drives, as well.



I'm now suspecting that I may have a hard drive issue. I left the Mac running overnight and look forward to checking on its status in the morning. The issue manifested itself every 45-50 minutes following intense disk read-write activity, which it won't get tonight.



However, I thought I'd post this online to alert others to a potential issue.



More to follow later.

Comments

  • Reply 1 of 4
    endymionendymion Posts: 375member
    Quote:

    Originally posted by Dave Marsh

    kernel[0]: IOATAController device blocking bus error



    I've seen a similar error in the past that was triggered when the drive went to sleep and the task trying to access it wasn't waking it back up.
  • Reply 2 of 4
    dave marshdave marsh Posts: 304member
    Thanks for the reply. I'll try unchecking the "Put hard disk to sleep when possible" option in the Energy Saver control panel on my utility startup drive to see if that helps.
  • Reply 3 of 4
    dave marshdave marsh Posts: 304member
    Apple agreed today to ship me a replacement drive to resolve this issue. I hope the replacement doesn't have the same issue!
  • Reply 4 of 4
    Apple replaced the hard drive and iDefrag works fine with the replacement Maxtor drive at work.



    I recently had this same issue crop up at home on my new 2.7GHz DP Tower. However, in this instance Apple refused to replace the drive, asserting that since only iDefrag appeared to have the problem, the problem wasn't their concern.



    In followup discussions with Coriolis Systems, they have acknowledged that others of their users have reported this problem, and that to them the issue seems to be with Apple's SATA controller. The issue manifests itself during extended data read/write activity with the Western Digital 250GB WD2500JD drive. Coriolis Systems has opened a ticket with both Western Digital and Apple to attempt to discover exactly what's happening.



    Since Apple won't replace the drive, I'll probably be purchasing a Hitachi T7K250 SATA drive in January, and using it for my startup drive instead. Then I'll use the WD drive purely as a data drive. The drive works fine in normal operations, and fragmentation shouldn't be much of an issue with it in this use. It's the startup drive that gets fragmented over several months of active use.
Sign In or Register to comment.