Linksys print server problems

in Genius Bar edited January 2014
I have a Linksys USB print server (model PSUS4) that I am trying to use to network two iMac G5's to print. when the G5's r connected directly to the printer (via usb) the printer works perfectly, but connect the printer to the Linksys, and the G5's cant find the matching configuration file for the printer, and when try to pick the printer from the list, it's not one of the choices. i have tried everything i could think of. the first G5 is running OS 10.3.5, the other is 10.3.6 (not sure if this makes a differnce or not). Although Linksys offers Appletalk as an option in the setup, they offer no support on their website, and since Epson wants you to buy thier $300 Ethernet interface card, i'm getting no help from them either. i've tried using both IP and appletalk, and not having used a Mac since System 7, i'm a bit lost on where to look for installed driver file(s), any help would be much appreciated.


  • Reply 1 of 3
    midwintermidwinter Posts: 10,060member
    1) What kind of printer is it? That could do something to something. You never know.

    2) Look here and see if there's anything useful.

    3) Look here and see if anything's useful. THIS LOOKS LIKE THE ONE FOR YOU.

    Let us know. I don't have this print server, but I'm willing to try to help out.
  • Reply 2 of 3
    peepspeeps Posts: 3member
    the printer is an Epson Sylus Pro 4000, i've tried all the steps in ur second link, and no dice.
  • Reply 3 of 3
    peepspeeps Posts: 3member
    after i install the printer, under name it calls it "Local System V Printer" insted of Epson Stylus Pro 4000. data gets to the priter, cause it says "Printing..." but doesn't do anything
Sign In or Register to comment.