Newbie ?: Can I connect a PC to a Mac with an Ethernet cable?

Posted:
in Genius Bar edited January 2014
Is it possible to connect a PC (Win XP) to a Powerbook 15" (with Tiger) using an ethernet crossover cable for the purpose of transferring files from the PC to the new PowerBook?



I've searched all over the place, but haven't been able to find the information explained in a simple manner...



Thanks!

Comments

  • Reply 1 of 10
    drumsticksdrumsticks Posts: 315member
    Short answer yes. The TCP/IP protocol is independent of operating system. You might have to manually specify IP addresses to get them to communicate, but otherwise, everything should be ok. On newer machines, you may not even need a crossover cable as the network card is smart enough to figure that out and do the cross-over internally...



    EDIT: This shouldn't be in current hardware, should it?
  • Reply 2 of 10
    argeliusargelius Posts: 309member
    I've tried doing the "connect to server" maneuver on the Mac. However, I'm at a loss to figure out what the IP address is of my Windows notebook (sitting 12") away...
  • Reply 3 of 10
    mynameheremynamehere Posts: 560member
    Quote:

    Originally posted by Argelius

    I've tried doing the "connect to server" maneuver on the Mac. However, I'm at a loss to figure out what the IP address is of my Windows notebook (sitting 12") away...



    For the ip type "cmd" (no quotes) into the Run box to get a command prompt window. Then type "ipconfig" (again, no quotes) into the command prompt. the ip, as well as various other info will come up.
  • Reply 4 of 10
    naknak Posts: 101member
    Quote:

    Originally posted by Argelius

    Is it possible to connect a PC (Win XP) to a Powerbook 15" (with Tiger) using an ethernet crossover cable for the purpose of transferring files from the PC to the new PowerBook?



    I've searched all over the place, but haven't been able to find the information explained in a simple manner...



    Thanks!




    Whenever I can't get something like that to work, I launch AIM on the pc, and iChat on the mac. Put everything in one folder on the pc, and then file transfer through your home-brew peer-to-peer network to the mac.
  • Reply 5 of 10
    Quote:

    Originally posted by Nak

    Whenever I can't get something like that to work, I launch AIM on the pc, and iChat on the mac. Put everything in one folder on the pc, and then file transfer through your home-brew peer-to-peer network to the mac.



    I didn't know AIM does Bonjour...? Care to explain how you got that to work? I'm curious myself...
  • Reply 6 of 10
    gene cleangene clean Posts: 3,481member
    He uses the 'Send File' function. It takes a while, as its very slow, but it does work.
  • Reply 7 of 10
    argeliusargelius Posts: 309member
    Thanks, everyone. I tried multiple times to get this to work (using both a direct ethernet cable as well as wirelessly), but continually kept getting "error code -36" errors. As far as I can tell, it has something to do with the Windows machine being set to us "plain text" passwords (as opposed to regular ones). Since I have XP Home, there is no way to (easily) change this, so I think I'll just do file transfers with an external hard drive. Sure would like to get this to work, though...



  • Reply 8 of 10
    newnew Posts: 3,244member
    my best experience is to activate the FTP server on the mac, and the log in with an FTP client from the PC...



    Or that is atleast what i think I did, the last time...
  • Reply 9 of 10
    tulkastulkas Posts: 3,741member
    Fault -36, I beleive is related to your firewall. Make sure that is opened on both PC's.



    I posted this a long time ago, but may still be relevant:

    -On PC and Mac, make sure the workgroup names are the same.

    On PC, this means Start->MyComputer->Rightclcik->Properties->Computer Name-> press Change. Should be Workgroup as the workgroupname.

    On Mac, Applications:Utilities launch Directory Access, click lock and enter password to admin, then click smb and configure. Make sure name is the same workgroup name as on PC.

    -On Mac, System preferences:Sharing Tab. Click on Windows File Sharing

    -On PC: Make sure you have atleast one folder shared.

    -To mount PC share on the Mac:Go menu, Connect to Server. If the PC shows up great, just click it. If not, enter the IP as smb://IP_Adress/sharename. Enter userid and password and you are set

    -To mount Mac shares on the PC:Start->My Network Places, Click Add Network Place. Click Next a few times, till you see a Browse button, click browse, expand Entire Network object until you see the Mac name there.



    Both the Mac and the PC have to have folders shared inorder to share.



    If either computer can't 'see' the other:

    -check cables

    -check workgroup names are the same

    -ensure folders are shared

    -pick up XP box and heave it out the Window.
  • Reply 10 of 10
    Dude, just use a flash drive.
Sign In or Register to comment.