No Devices or Volumes Will Mount

in Genius Bar edited January 2014
I am running Mac OS 10.3.9 on an iBook G4.

Recently, for no apparent reason, my computer has started refusing to mount any volumes or devices other than the start-up disk and Disk Images. So I cannot use FW Hard Drives, iPods or Optical Disks.

The devices do show up in System Profiler but not in disk utility, the Finder, or any applications including the terminal.

When I insert an optical disk, the drive spins for about 5 sec and then goes dead. The disk gets stuck and I have to emergency eject on restart. However I can start up from a CD.

I've tried lots of generic maintenance tasks - so far I have run all maintenance scripts, repaired permissions, cleared all caches, redone prebidings, deleted some preference files, reset PRAM and PMU. None of which has made any difference.

I have tried to repair the start-up disk, but it fails to verify. FSCK also fails and so does starting up in safe mode.

I am fairly lost as to what to do next. I can't think of any logs to check because there are no crashes occurring, just a complete lack of any response.

Strangely, other than this one major problem, my iBook is running fine.

Any suggestions?



I have the same problems in single user mode, no devices show up in the /Volumes directory.

I'm trying to find out how to reset my "rc" start-up script to its factory defaults. I know that someone I know had tried to edit this around about the time these problems started.


  • Reply 1 of 4
    lundylundy Posts: 4,466member
    Strange. All that I can think of to try is resetting the firmware.

    command-option-O-F on boot

    then at the OF prompt type


  • Reply 2 of 4
    squidthingsquidthing Posts: 124member
    I tried resetting the firmware but it has made no difference.

    However I have tried starting up from the installation CD and the Disk Utility has access to optical disks, the internal HD and external drives. This makes me think that it must be a problem within the system folder rather than any sort of hardware or firmware issue.

    I'm currently looking at any plists that I can try and replace.

  • Reply 3 of 4
    squidthingsquidthing Posts: 124member
    ^ ^ ^
  • Reply 4 of 4
    squidthingsquidthing Posts: 124member
    Does anyone know how to to reset my rc start-up scripts to their factory defaults? Can I just remove them so they are replaced on restart, or do I have to recreate them via a command line command?

Sign In or Register to comment.