Major BUG, HELP!!!!!

in Genius Bar edited January 2014
All of a sudden all my operating system text is an A with a box around it. All menus, application titles, icon names everything. I don't know when anything says. Here is a link to an image of what I'm talking about


  • Reply 1 of 12

    Have you tried repairing the permissions to see if it helps in any way.

  • Reply 2 of 12
    tried to repair the permission and zapped the pram but neither worked.
  • Reply 3 of 12
    ebbyebby Posts: 3,110member
    I had a problem where letters would disappear completely and leave an empty space. I fixed it by using OnyX to delete the User Cache, System Cache, Font Cache and Virtual memory files.

    I'm guessing the Font Cache is the problem, but upon restart, everything is rebuilt.
  • Reply 4 of 12
    Thanks for the suggestion but alas even after clearing out all the caches it still didn't work
  • Reply 5 of 12

    Do you have any crash logs in your /Library/Logs/Crash Reporter if there is it may just give an idea to what has caused it to happen.

    Or also you could try booting from the install CD/DVD and seeing if there are any errors by verifying the hard drive.

    When you you type does everything look normal.

    I have one other strange but it could be it a corrupted keyboard layout as these are contained in the main system folder.

  • Reply 6 of 12
    If he used OnyX and cleard all the logs he will not be able to view much.
  • Reply 7 of 12
    Sorry, previous post I made not too helpfull, Lets try this, did you mess with your fonts in any way at all? If you used a font program perhaps you are missing system fonts? Also, in Prefrences make sure English is at the top for your language prefrences. Good Luck.
  • Reply 8 of 12
    xoolxool Posts: 2,460member
    If you make a new user account does it have this problem? This will tell you if it some user-specific or system level problem.

    Also, try restoring all your fonts to the default font files installed by the OS. Remove any custom fonts you've installed in the various font locations. Give 'er a restart and maybe that will fix it.
  • Reply 9 of 12
    I have tried making a seperate user account and I haven't installed any extra fonts. The thing is the problem started just in firefox but then when I restarted it was throughout the entire system. How would I reset the default fonts?
  • Reply 10 of 12
    Some new discoveries. If I highlight the file name so that I can rename it, I can see the filename. If I do rename it though and hit enter it goes right back. I don't seem to think its a font problem since there doesn't seen to be any correlation to the number of A's and the number of letters in what they represent. I think I may win the prize for finding the only os x virus ever.

    Here is the contents of my system\\library\\fonts folder

    Apple LiGothic Medium.dfont







    Times LT MM




    Geeza Pro.ttf


    Geneva.dfont ???????????????????????? Pro W4.otf

    Hei.dfont ????????????????????? Pro W3.otf

    HelveLTMM ????????????????????? Pro W6.otf

    Helvetica LT MM ???????????????????????? Pro W3.otf

    Helvetica.dfont ???????????????????????? Pro W6.otf

    Keyboard.dfont ???????????????????????? Std W8.otf


    ?????? Pro.ttf





    I have no idea what all those question mark files (the names actually have all those question marks in the name)are.

    Also I have a bunch of duplicate fonts according to font book but I can't do anything to get rid of them because I can't see the menu choices. And is there a way that I could have changed the font somehow and if so how could I change it back. (Although I still don't think it is a font problem)

    Just to give you an idea of what I was doing when this occurred, I was just using iTunes and rewinding a song a couple times in a row. I closed iTunes and started Firefox and low and behold A's everywhere. Restarted and then A's were with everything associated with the Finder.
  • Reply 11 of 12
    ebbyebby Posts: 3,110member

    Hate to burst your bubble, but it is probably not a virus. (If I were a virus writer, I could think of all kinds of more important things to do to your computer)

    Most likely something in your system is pooched. I had a VERY persistant bug last year where everything that used colorsync would display red as magenta. If I cleared the cache and restarted, it would look normal, but on the second restart everything would get funky again. One day it magically stopped doing that.
  • Reply 12 of 12
    lundylundy Posts: 4,466member
    I vote for running Disk First Aid from the install CD.

    Those filenames may or may not actually be the filename - it could be that they are just displaying incorrectly.

    If the disk checks out OK, I think you are going to wind up doing an archive and install, unless there is something on the Mac Discussions about this, stating which pref file is torqued.
Sign In or Register to comment.