iPhoto: after reinstallation, unable to edit photos

Posted:
in Mac Software edited January 2014
Here's my story. Being a Mac newbie, I didn't realize I should never, ever move any of the iLife apps from the root of the Applications folder. Anyway, I moved iPhoto and it stopped working. I tried moving it back, but it still was dead.



Using Pacifist I was able to reinstall iPhoto from the restore disc that came with my Mac Mini. Curiously, I was unable to do this from the restore disc that came with my PowerBook; using Pacifist, iPhoto was not to be found; doing a "Reinstall bundled applications" directly from the disc, the error "this package is damaged and cannot be read" came up. (Apple is sending me a new disc).



After launching iPhoto, the spinning do-dad spinned for HOURS while it searched for photos do add. I tried a "rebuild library" maneuver (by holding cmd+option while launching iPhoto), with the same, endless "Loading photos..." spinning thing.



During this process I wiped clean and reinstalled Tiger on my Mac Mini and did a "Migration Assistant" as a back up of my PowerBook on the Mini. Curiously, after doing this, the iPhoto library on the Mac Mini worked without problems.



I then copied the following files from the Mac Mini's iPhoto Library to the same location on the Powerbook (AlbumData.xml, dir.data, iphoto.db, iphotoi.pspot, iphoto.lockdata, Library.iphoto, thumb32.data, thumb64.data, thumbjpg.data).



After doing this and relaunching iPhoto, the same spinning "Loading photos...". However, if I click on the "slideshow" icon the "Loading photos..." stops and the thumbnails/library shows up intact.



Anybody still awake?



I thought all was saved, but:

[1] Every time I launch iPhoto, I have to click on 'slide show' to get thumbs to show up



[2] If I right click on a photo in the library, "Edit""Edit in separate window", "Edit in an external editor" and rotate options are all grey-ed out. (Also, clicking on the "Edit" or rotate icons, have no effect.



So, any ideas what's going on? (I've done the 'repair permissions' thing many times, as well as a Mac Janitor routine). I also checked to see that the iPhoto Library is set for me (the owner) to Read & Write.
Sign In or Register to comment.