Final Cut Studio Help

in Genius Bar edited January 2014
I had been running Final Cut Pro III on my 15" powerbook for a couple years and never had problems. About a month ago, after realizing I don't travel that much, I sold my PB and bought the new iMac. One of the first things I tried to do was load FCP III on to it only to run into a couple problems. I called applecare and they told me that the new iMacs wouldn't run anything under FCP IV (which upset me since I told the sales person what I would be using on my new machine). Luckily, I'm a student and was able to buy the newest version of FCP Studio academic.

I installed it and Motion, Soundtrack Pro.....everything works fine EXCEPT Final Cut. I'm able to import files from my hard drive and external hard drive but when I connect my camera (Sony VX2100) to capture clips it does this freezing thing. When I hit play my camera starts playing but my log and capture window just freezes on the first frame that comes up and FCP stops responding. Sometimes I'm able to push stop on my camera and it will respond but most of the time I have to use the force quit option.

I'm no expert at FCP and have always used the stock settings but I have never run into this problem. Even some of my friends who are pretty good with the program don't know what's wrong. I was on hold with applecare for 45 mintues this morning but had to leave to come to work. Since I won't be home to call again for 8 hours I thought I would see if anyone has a suggestion.


  • Reply 1 of 1
    Well on a chance I tried it again and it's working fine. Still not sure what happened but as long as it's working I'm not gonna question it.

    Now if only Motion wasn't so confusing....
Sign In or Register to comment.