Sendmail: How do I tell if it is on and working properly?

Posted:
in Genius Bar edited January 2014
I have installed PHP 5.03 on my Mac (10.4.3) running apache 1.3 (what came with Tiger) and I have a contact form setup that does work but the mail message never gets to me.



I am assuming I have a problem with sendmail. Anyone have any experience with this?



TIA

Comments

  • Reply 1 of 3
    you need to get "postfix enabler" from versiontracker. it used to be free but since Tiger came out you have to pay $10 for it. worth the money IMHO.
  • Reply 2 of 3
    aplnubaplnub Posts: 2,584member
    Quote:

    Originally posted by MagicFingers

    you need to get "postfix enabler" from versiontracker. it used to be free but since Tiger came out you have to pay $10 for it. worth the money IMHO.



    Thanks for the tip. It looks like it has been replaced by MailServe.



    I have a question for you. Would sitting behind a router cause PHP not to be able to send an email out?
  • Reply 3 of 3
    you probably need to open port 25 and 110 to the ip of the computer you are using for sendmail. on my lynksis router I go to the "applications and gaming" section of the router and put the port numbers "start 25, end 25" in one line then "start 110, end 110" on another line and fill in the ip address. for the "protocal" i just leave it on "both" then check the enable box and click the save button.

    l also have a line set up for port 80 for a website i serve. just make sure you put in the proper ip for the comp and it should work.
Sign In or Register to comment.