How to recover from firmware update failure?

in macOS edited January 2014
I received a call today from work (it's a holiday for me) concerning a problem with a 17" PowerBook. The caller reported that the user's laptop was locked up and to help them, held down the power button to force a restart. Unfortunately, they held the power button down until the firmware update tone came on. Of course, there was no firmware software to be installed, so they shut the Mac down and tried again. Now, every time they press the power button to restart, it returns to firmware installer mode.

How do I cancel this firmware update cycle? I've tried having the caller remove the battery, power cable, and holding down the power button for 5 seconds, but that didn't help. I'll be working on this laptop tomorrow, so I'm wondering how to proceed. I'm not even sure I'll be able to startup the PowerBook from an external hard drive, since something in the hardware seems poised to execute.

This is a 2-year old 17" PowerBook running Panther 10.3.9.

Thanks in advance for any ideas.


  • Reply 1 of 3
    gene cleangene clean Posts: 3,481member
    Tell them to hold 'Option' down when the computer starts and see if it allows them to boot from the internal drive from there.

    If not, they can do an archive and install using the same method.
  • Reply 2 of 3
    Thanks for the suggestion. I plan on trying to startup from my external firewire utility tomorrow to check out the PowerBook.

    I was just concerned that the firmware may have locked something in hardware, so that any attempt to startup from any hard drive would fail. If that's the case, something on the logic board will have to be reset to a default state, and beyond looking for a button to push on the logic board, I'm out of other ideas to try.

    If this is the case, does anyone know of any key combinations to try at startup?
  • Reply 3 of 3
    Well, not much luck today. The PowerBook kernel panicks whenever it's booted from a hard drive, either the internal or an external FireWire drive. It boots from Apple's OS X installer disks just fine. So, I did so and ran Disk Utility/Repair Volume and Repair Permissions. It said all was fine. Then I rebooted and ran Apple's Hardware Test 2.5, and again it found everything was OK. So, I booted into Open Firmware (cmd-opt-O-F) and entered reset-nvram and reset-all, with no effect. I then tried zapping the PRAM (cmd-opt-P-R), again with no effect.

    I was successful in booting the laptop into Target FireWire mode, so I transferred the users apps/data/account over to another Mac, reformatted the laptop's hard drive, and reinstalled MacOS X 10.4. Upon reboot, the Mac again kernel panicked. So, I rebooted into Safe Mode (cmd-S) and finished the installation process for MacOS X 10.4, logged in, and went to the Desktop to assure everything had transferred successfully. All appeared well, so I rebooted, and again the Mac kernel panicked.

    At this point it's clear that something is preventing the ATA/FireWire bus from booting any hard drive. When I asked the caller yesterday to hold the power button down and force a reboot, they held it down all the way to the firmware update tone, which I'm now suspecting may have locked up something on the logic board. Of course, it's also possible that yesterday something else failed on the logic board that the hardware test didn't discover, but I've run out of ideas.

    So, I called AppleCare, reiterated all of the above, and they opened a ticket for the laptop. I'll be taking it in tomorrow, so we'll see what they do to fix it.
Sign In or Register to comment.