How do I reset my Clock!?

Posted:
in Genius Bar edited January 2014
My powerbook ran out of battery, to the point of shutting down. When I restarted it thought it was 1969. OK, so i clicked and unclicked Automatically set time a million times in the Pref Pane and it didn't do anything. Huh!? That always worked before. How do I force it to query NTP? I cleared PRAM hoping that would help. Is this some sort of 10.4.4 bug? I just want it to set time automatically. And actually DO it. Thanks for the help!

Comments

  • Reply 1 of 6
    Have you tried setting it manually in the Date & Time prefpane if automatic timeserver sync doesn't work?



    If it still refuses to maintain the time, you may need a new clock battery, but while it's on main battery or plugged in, it should hold time OK.
  • Reply 2 of 6
    andersanders Posts: 6,523member
    Quote:

    Originally posted by Aquatic

    My powerbook ran out of battery, to the point of shutting down. When I restarted it thought it was 1969. OK, so i clicked and unclicked Automatically set time a million times in the Pref Pane and it didn't do anything. Huh!? That always worked before. How do I force it to query NTP? I cleared PRAM hoping that would help. Is this some sort of 10.4.4 bug? I just want it to set time automatically. And actually DO it. Thanks for the help!



    Please don´t kill me. But did you have an internet connection at the time
  • Reply 3 of 6
    aquaticaquatic Posts: 5,602member
    Yes sir, Ethernet ready to go. Will reboot in verbose and see what it says. Dang you guys are fast!
  • Reply 4 of 6
    aquaticaquatic Posts: 5,602member
    Oh how do you permanently enable verbose mode? Can't find it on macosxhints.com. In console it says that it couldn't find a suitable server for ntp update. But it's connected w/ ethernet at boot. And so I'm at a loss as to what's going on.
  • Reply 5 of 6
    mr. hmr. h Posts: 4,700member
    Quote:

    Originally posted by Aquatic

    Oh how do you permanently enable verbose mode? Can't find it on macosxhints.com. In console it says that it couldn't find a suitable server for ntp update. But it's connected w/ ethernet at boot.



    What happens if you manually change the clock to something nearly right (most important is the date), then try to do a network time update?
  • Reply 6 of 6
    aquaticaquatic Posts: 5,602member
    I tried that as well. Doesn't do anything. IS there a terminal command or something to make it renew time from NTP?
Sign In or Register to comment.