fixing firewire and ethernet ports

in Genius Bar edited January 2014
I have a powermac G4 500 Mhz with AGP graphics. It has 768 megs of RAM. OS 10.3.0. It was given to me by a friend recently.

Shortly before he gave it to me the firewire ports stopped working. I read some reports through google that updating to 10.3.9 could fix this. It worked for a few people.

This brings up a new problem. When I plug an ethernet cable into the built-in ethernet port and into my router I can't get it to lease an IP address via DHCP. It also has a PCI ethernet card but that doesn't work either. System profiler doesn't recognize it (although the lights on the card to light up).

So really, my main problem is the ethernet. I have a working firewire card that I could install, but I would really like to have this on the internet.

If anyone has any ideas, please let me know.

By the way, this is a fresh install of 10.3 off of retail cds.



Edit: The firewire ports died for my friend just after he tried turning the computer on in target disk mode. They ports still supply power, as I can charge my ipod, but under system profiler it says "no information available".

I've gotten the ethernet working, so now I just have to figure out what's wrong with the firewire.


  • Reply 1 of 2
    Also, it has a small red led that is lit up near the edge of the motherboard closest to the RAM slots. Is this normal? I'm just not sure if it's always there or some kind of indicator light.

  • Reply 2 of 2
    ebbyebby Posts: 3,110member
    a PCI ethernet card would need drivers. I have a D-Link ethernet card and the system didn't recognize it until I installed the software.
Sign In or Register to comment.