New iCal problem!

in Genius Bar edited January 2014

Mac Mini 1st generation, Panther 10.3.9.

I just installed the latest security fix and then iCal started behaving differently from earlier. There are two problems:

Problem 1


When I create a new appointment (or Event as iCal calls it), and I switch to the Month view, I only see the time and not the event itself. For example, if I make an appointment for 8:30 a.m. on Tuesday for a Physio appointment, I only see the 8:30 and not the word "Physio".

I can see everything properly in the Day view or even the Week view. Only the Month view misbehaves.

This was not the case earlier. I used to be able to see everything in the Month view too! In fact, I can still see everything in the Month view for the appointments I made before I installed the security fix. The problem exists only for any calendar entries I made after the security fix.

Has anyone else had this happen?

And yes, I repaired permissions and I even restarted the machine.

I thought it might have something to do with iCal preferences, but I could not find anything that looked like it was related to this.

Problem 2


I subscribe to the F1 (Formula 1 racing) calendar from Apple's website. The calendar does not display in iCal! I subscribe to a few other calendars (Canadian Holidays, US Holidays etc.), they all display properly, it is only the F1 calendar that seems to have this problem.

I even downloaded the calendar and double-clicked on it, I tried to refresh the calendar, I even deleted the calendar and subscribed to it fresh, nothing works.

Any ideas on how I can get this to work?

Thanks and cheers


  • Reply 1 of 6
    regreg Posts: 832member
    I could not duplicate problem #1. Mine works properly iCal 2.0.3 running 10.4.5

    The problem with F1 and several others from the apple site is that they have not been updated. Resubscribe to F1 and you will find all dates of 2005 filled in. You might shot a feedback to apple to update that ical calendar.

  • Reply 2 of 6
    tilttilt Posts: 396member
    Thanks Reg. Maybe problem 1 manifests itself only in Panther and not in Tiger? Maybe someone who has Panther 10.3.9 could let me know if they have a similar problem.

    Re, problem 2, thanks. I shall shoot off a note to Apple and hope they will update the calendar

    Thanks and cheers
  • Reply 3 of 6
    r3dx0rr3dx0r Posts: 201member
    there's an option in icals preferences called 'show time in month view'. do you have that turned off ?
  • Reply 4 of 6
    tilttilt Posts: 396member
    Thanks r3d, that option is turned on. My problem is NOT that it does not show the time, my problem is that it shows ONLY the time and not the event itself

  • Reply 5 of 6
    r3dx0rr3dx0r Posts: 201member
    ah i see

    did you try deleting icals preferences ? usually located in /Users/<Username>/Library/Preferences/

    maybe the plist got corrupted somehow. aside from that i don't know what could be the cause.
  • Reply 6 of 6
    tilttilt Posts: 396member
    Thanks r3d. I tried that and then i could see the event, but not the time. So I went back to iCal preferences and turned on "Show time in Month view" and then it was back to the same old problem, I could only see the time and not the event. I turned that preference off and I could now aagain see the event but not the time!

    Oddly enough, as I mentioned earlier, this problem only occurs for eventrs created AFTER installing the security update. Events created before the security update show both the time and the event. Weird huh!

Sign In or Register to comment.