my login isnt working anymore.. cant get into my desktop, please help!

in Genius Bar edited January 2014
ok well i have an old powerbook g4 (titanium). sometimes when i move a certain way on my bed or whatever the thing wigs out and goes to sleep. this happens very often but i just press a key to wake it up.

well today when it happened everything suddenly went wrong. my saved passwords didnt work anymore and then when i restarted the machine itself it took me to the login screen (which it never does) and the password i made it with doesnt work to get in either!

i have data in there that is so precious to me but i have no idea what to do. any advice guys? everything is fine except i just cant get into my desktop! thanks

p.s. im using panther 14.9 and underneath the Mac OS X logo on the login screen it still has my username underneath it so im guessing my harddrives data isnt gone


  • Reply 1 of 3
    i used the OS X install disc to reinstall with the "archive and install" option selected instead of "erase and install"

    that didnt work either. i repaired everything with disk utility and that didnt work either. however in disk utility where it says "mount image" i was able to look at the harddrive contents and it seems all my files are still in there!

    please someone tell me a way i might be able to back these up! i cant login but everything else works fine.
  • Reply 2 of 3
    MarvinMarvin Posts: 14,436moderator
    When you say archive and install didn't work, what do you mean? It didn't install?

    Before doing something drastic like that, I would have tried resetting the main password.

    I take it you migrated your old data across after the archive and install? If so, the problem may be in your user account. Possibly if you used the home folder encryption, your sparse image may have gotten corrupt.

    If resetting the password doesn't work, I'd try archive and install but don't migrate your data. This will keep your home folder but make a new user.

    If none of that works, I'd buy a firewire hard drive. I recommend Lacie. Then install OS X onto it, boot from it and copy your data. The reinstall you system and copy the data back.
  • Reply 3 of 3
    hey man thanks for the reply

    yea, i tried resetting my password but the user name wasnt showing up in the pulldown menu (only sysadmin and appserv were showing or whatever theyre called.) so then i did the archive and install and it didnt work either (it installed but the login thing still came up and not working.)

    i was going to do another install, without the "save user and network settings" option enabled but it turns out that the last install added some space to my computer and now i cant install it because my hard drive is full . i tried to delete some files through open firmware but i cant figure out how (if its even possible, because i pretty much know how to do everything else with it.)

    the harddrive thing was definitely my final choice and i will do it this weekend if i am not able to delete some files to free up space with open firmware. THANKS for your reply!
Sign In or Register to comment.