webserving from home mac and netgear dg834g

Posted:
in Genius Bar edited January 2014
hello all



i could do with some help setting up a webserver. as the topic says its my mac (mini, 10.4.6) at home behind a netgear dg834g. i also have a static ip address with my isp so i'm not using dyndns or anything. that part all works fine, i have managed to remote desktop over the internet (not vpn) to both macs and pcs.



i can see my index.html page just fine if i go to http://myip/~myshortusername but the address in my browser jumps to http://mymacnetworkid.local/~myshortusername/. i asked someone to check http://myip/~myshortusername and they cannot see the page, so it seems i'm just being bounced around on my local network and my page is not visible from the internet.



i enabled personal web sharing in both services and firewall on the mac. i also forwarded port 80 to my mac from my router (before i took this step http://myip/~myshortusername didn't work even for me locally, not it does).



when someone from the internet tries http://myip:80 they get the standard apache 'seeing this instead of your expected page?' thing. also http://myip/~myshortusername:80 brings up another apache page but not the standard one and not my page.



if anyone knows how to get it working i'd appreciate your time. thanks in advance.

Comments

  • Reply 1 of 3
    I think you need to put your web site in /Library/Webserver/Documents/

    Then if you go to your ip# it will see your site instead of the standard apache webstuff apple has in there.
  • Reply 2 of 3
    ahh! thank you very much, it works just fine now
  • Reply 3 of 3
    Is the macmini the only node on the network or are you using NAT?



    If it is the latter, you need to forward port 80 to the private IP on the mac mini. I would suggest enabling static routing for the mac or setting it to a static IP on the machine.



    With apache running properly you will be able to go to http://[your-pubic-ip]/ and see the page. Check the directive variable in apache, make sure the index you are using falls in that list of files.
Sign In or Register to comment.