Macbook Pro Wireless problem

in Genius Bar edited January 2014
Please be kind as I am still a little new to Macs

I just got my Macbook Pro yesterday and it is really fast and I love it, but I am having some irritating problems with it.

1. When I first start it up it fails to connect to the wireless network, it seems to have the wrong password remember which I have tried resetting by deleting it from the keychain but everytime I restart it is not working again. When I look at the network in the Network Panel it says it is WP2 Personal (the network is WPA +TKIP) and if I show password its something like $00000000000000000000000000000000000000000000000 also incorrect.

From my log file:


May 2 10:08:32 novaoblivions-computer /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport: Error: password required for "LINKSYSHOME" not found in keychain

There is an entry for LINKSYSHOME in the keychain though.

The second problem is Spotlight doesnt search sometimes but if I reboot it works fine, when I click on it or hit CMD+Space it does the little spinny icon for about a second then stops and tells me there is nothing found. If I try closing it and doing it again it doesnt even have the icon pop up it imidiatly says nothing found. I have tried forcing it to rebuild the index by making the drive private and then removing it but it still wont work. The strange thing is that spotlight still works from a Finder window or in

Any help would be great, the sad thing is that windows XP runs fine lol so I dont think its a hardware problem I must have just mesed up a config file somewhere. I have tried resintalling the 10.4.6 combo update but that didnt help either. My brother has the exact same computer and it suffers from the same networking problem, he does not have bootcamp installed.

Wireless router is Linksys WRT54GS and is sitting about a foot from the computer so the signal is strong. Firmware: DD-WRT v23 (12/25/05)

Macbook specs: 15" 2.0Ghz, 1Gb Ram, 120Hd, everything else stock, Bootcamp installed on 15gb Partition.

I can grab the log file if needed.

I have of course tried rebooting the router. It also seems to mess up when I come back from standby mode. Turning airport off and then on again seems to fix that though. It seemed to work fine before I installed the 10.4.6 update.

Oh I should mention that I had a 15" Powerbook before and it connected to this very same network with no problems at all.


EDIT: The Wireless problem has been fixed the solution is here:

Sign In or Register to comment.