Mail not accepting password.

in Genius Bar edited January 2014

I am on Panther. is suddently behaving oddly. It asks me to enter the password for a POP server that has been working perfectly for the last one year. And when I enter the password, the window pops up again immediately asking for the password again, like either I gave the wrong password or something. The only way to get out of this cycle is to hit 'Cancel' and then that account is taken offline!

My POP server also has a web interface. I logged in via the web interface to see if the problem lay with the server. Nope. The server is fine, I was able to log in and check my mail using Safari. It is only that has this problem.

I tried restarting the macine (you can tell I came from Windows *grin*), I tried repairing permissions, nothing helped.

This is my main email account, so I desperately need this to be working. Any suggestions would be greatly appreciated.

Thanks and cheers


  • Reply 1 of 8
    kickahakickaha Posts: 8,760member
    Check the settings in the Mail preferences.

    Mail -> Preferences -> Accounts

    Click on the proper account, and make sure that the *server* information is correct compared to with what your ISP provides when you call them. (ie, call them to double-check, they may have changed something on their end that their webmail interface already adapts for.)

    Also, if you can give any more information about what the error is, it should tell you (and us) where the problem is in the chain.
  • Reply 2 of 8
    tilttilt Posts: 396member
    Thanks Kickaha. The account settings are OK, I checked.

    If you can tell me how to take a screenshot of a window in MacOSX (I tried Help but that only spoke about using "Grab") I can attach a screenshot of the error for you.


    Edited to add: Sorry, I remembered how to take screenshots. Thank you Here is the screenshot:

    Hmm... Why am I unable to paste my screenshot here?

    Edited again to add: The screenshot is saved as a PDF file. How do I attach it here for you to see? Thanks
  • Reply 3 of 8
    tilttilt Posts: 396member
    This is weird! It just started to work again, automagically!!! Something's happenin' here, what it is ain't exactly clear as the song says!

    No change in settings, no nothing! Just started to work!

    I hate it when a pattern cannot be established!

    Thanks Kickaha, I appreciate your jumping in


    Edited to correct typo and to add: BTW, the error message said "The POP server "" rejected the password for user "14603461", please re-enter your password, or cancel.
  • Reply 4 of 8
    tilttilt Posts: 396member
    And now it has once again stopped working and popped up the same error message. God, this is frustrating!
  • Reply 5 of 8
    kickahakickaha Posts: 8,760member

    Originally posted by tilt

    And now it has once again stopped working and popped up the same error message. God, this is frustrating!

    Well if nothing is changing on your end, then something must be changing on theirs. Have you called the ISP?
  • Reply 6 of 8
    tilttilt Posts: 396member

    Originally posted by Kickaha

    Well if nothing is changing on your end, then something must be changing on theirs. Have you called the ISP?

    My ISP is not my mail service provider. My mail service provider is a free service based in Germany called GMX. I went on to their web site to check if anything has changed in terms of configuration etc., nothing has.

    I think I'll wait to see if this problem lasts another day. If it resolves itself then it could just be some kind of glitch. If it does not, then it is a serious issue and maybe I shall just have to change my mail service provider

    Thanks again
  • Reply 7 of 8
    curiousuburbcuriousuburb Posts: 3,325member
    I have had repeated instances of Mail going crufty with the password occasionally, and with several different ISPs/MailServers and email addresses over the years.

    The "server blah rejected the password for user blah" dialog was all too common.

    I sometimes got it several times a day on multiple mail accounts, then it would be fine for months. Every now and then it recurs. This has happened in various OS versions since 10.2 and the last instance was last month under 10.4.6

    After many discussions with the various ISP gnomes and Apple folks in various setups over the years I was led to believe that part of the problem lies with the frequency of checking which Mail tries, but some MailServers don't seem happy to support (for reasons never exactly made clear).

    The temporary fix has usually been to reset the "check every 5 minutes" setting in Mail's prefs and bump it up to something like 10 or 15 minutes. Some servers don't like checking too often, apparently.

    Sometimes this solves the problem.

    It also appears that Keychain loses the plot at times. I've had it lose the password cookies for AI and other sites on occasion (sometimes after a Safari crash, sometimes a System reboot).

    It may be that a combination of quirks are contributing to similar, yet indistinguishable errors.

    Your Mileage May Vary.
  • Reply 8 of 8
    tilttilt Posts: 396member
    Thanks Curious. Yes, I have had this problem with some of my other mail service providers, but this is the first time it happened with GMX, so I never thought it could be my Mac that is the problem. is set to check mail once every 16 minutes because my mail servie providers have a minimum 15 minute interval requirement.

    BTW, this morning I found every one of my mail servers offline (in I just brought them all online and every one of them is working now. Let's see for how long they continue to work

Sign In or Register to comment.