Mouse pointer freeze on Macbook

Posted:
in Genius Bar edited January 2014
Hi,



Has anyone experienced this: When I am in Safari, whenever I click on a link or click back to get back to the previous page or any time I go to any new page by any means, my mouse pointer freezes for a few seconds, up to a maximum of 7-8 seconds, during which time, whatever I do on the trackpad, the mouse pointer just will not budge. After that time, the pointer responds to the trackpad.



I have a Macbook, the only non-defaut thing I have enabled is the two-finger right-click (place two fingers on the trackpad an click the button for a right-click).



Cheers

Comments

  • Reply 1 of 4
    dac0nvudac0nvu Posts: 175member
    Quote:

    Originally posted by tilt

    Hi,



    Has anyone experienced this: When I am in Safari, whenever I click on a link or click back to get back to the previous page or any time I go to any new page by any means, my mouse pointer freezes for a few seconds, up to a maximum of 7-8 seconds, during which time, whatever I do on the trackpad, the mouse pointer just will not budge. After that time, the pointer responds to the trackpad.



    I have a Macbook, the only non-defaut thing I have enabled is the two-finger right-click (place two fingers on the trackpad an click the button for a right-click).



    Cheers




    I've experienced this from time to time. However, since this is my first Mac and first trackpad, I just figured that it's kind of flaky. Also my cursor jumps all over the place sometimes. The cursor freezing happens to me nowhere near as often as it seems to happen to you though...and I've had this happen outside of Safari.
  • Reply 2 of 4
    MarvinMarvin Posts: 14,209moderator
    I'd check with an external mouse to see if it's just a trackpad issue or a general mouse pointer issue.



    Quote:

    Originally posted by dac0nvu

    I've experienced this from time to time. However, since this is my first Mac and first trackpad, I just figured that it's kind of flaky. Also my cursor jumps all over the place sometimes.



    Try going to System Prefs>Keyboard&Mouse>Trackpad and select ignore accidental trackpad input.
  • Reply 3 of 4
    dac0nvudac0nvu Posts: 175member
    Quote:

    Originally posted by Marvin

    I'd check with an external mouse to see if it's just a trackpad issue or a general mouse pointer issue.







    Try going to System Prefs>Keyboard&Mouse>Trackpad and select ignore accidental trackpad input.




    Yep, already selected that when I selected the other stuff. I can't remember where, but I thought I read somewhere that it might have to do with resting your wrists *near* the trackpad and it was suggested not to do so. That may be the problem.
  • Reply 4 of 4
    tilttilt Posts: 396member
    The same thing happens even when I do not rest my wrist at all.
Sign In or Register to comment.