Help! Macs can't see each other

Posted:
in Genius Bar edited January 2014
Hi



I have heard so many stories that when two Macs are placed in a network they automatically see each other and can transfer files amongst themselves etc. Unfortunately it is not happening for me.



I have a Mini running Panther 10.3.9, a Macbook running Tiger 10.4.7, they are on my home network, neither knows the other is there. The network looks like this:



A cable modem is plugged via ethernet cable to a netgear router

The Mini is plugged into the netgear router with an ethernet cable

An Airport Express is plugged into the netgear router with an ethernet cable

The Macbook gets its mojo from the Airport express wirelessly.



My firewall is turned on in both, under the Service Tab in the Sharing preferences, nothing is turned on in either machine, under the Firewall tab in Sharing Preferences, nothing is turned on.



I am able to surf the web, check and send email etc. from both machines, so there is no problem there.



Please help!



Cheers

Comments

  • Reply 1 of 19
    In Sharing prefs ... turn something on! (probably "personal file sharing").
  • Reply 2 of 19
    tilttilt Posts: 396member
    Quote:
    Originally Posted by KingOfSomewhereHot


    In Sharing prefs ... turn something on! (probably "personal file sharing").



    Tried it, no use!



    Should I try connecting the Macbook directly to the netgear with an ethernet cable instead of through the airport express? Would that (should that) make a difference?



    Cheers
  • Reply 3 of 19
    lundylundy Posts: 4,466member
    What do you mean, "they can't see each other?"



    Are you logging in to one from the other? You have to.



    See what is listed under "Network" in the Finder Sidebar, after setting "Personal File Sharing" on in both machines.
  • Reply 4 of 19
    tilttilt Posts: 396member
    Hi Lundy,



    What I mean is, for me to even log into a machine, I first have to see that machine in my Finder or somewhere so that I can click on it to log in or mount a volume or anything. I cannot see that other machine. When I click on my "Netork" tab in Finder all I see is just the Macbook alone and nothing else.



    I do not know if I am explaining this properly, but this is the bet I can do I am afraid
  • Reply 5 of 19
    lundylundy Posts: 4,466member
    See if you can ping one machine from the other.



    Open Network Utility in the Utilities folder and put one the other machine's local IP address in the box and hit Ping.
  • Reply 6 of 19
    MarvinMarvin Posts: 14,209moderator
    If you have stealth mode on in the firewall, that may not show up the machine automatically. I think that's supposed to make sure people can't even see there's a machine on the network.



    If it's not turned on, it may be just the Finder not working correctly as per usual. Sometimes the network thing doesn't work for me.



    What I nearly always end up doing is opening the network utility and getting the ip address from there. You could probably get it from the sharing preferences window. I use network utility because I have airport and ethernet connections and it seems to prefer airport by default so I have to manually type in the ethernet ip. Ethernet is usually en0 and airport en1.



    To use the IP, click the go menu in the finder and choose connect to server and type in the IP.



    I've found AFP to be horrible over wireless btw. For anything over 10MB, I just end up hooking up an ethernet cable.
  • Reply 7 of 19
    tilttilt Posts: 396member
    I tried to connect the Macbook to the Netgear using the ethernet cable, opened Internet Connnect and did something, i do not remember what, all of a sudden I could see the other Mac, I was able to log in and transfer my iPhoto and iTunes libraries!



    I wished I had concentrated more on what I was doing because then i can explain it to you out here The only thing I rememebr doing is that after connecting with the ethernet, I turned on Personal file sharing on both machines.



    The trouble is, I had personal file sharing turned on even earlier when i connected through the Airport Express, but I guess I needed to connect directly and to create a new network!



    All I know is, my job is done, now I do not have a need to ever connect these two machines again.



    Thanks again everyone. I am saving this thread locally so that in the future if I ever have to do this again I shall have a point of reference



    Cheers
  • Reply 8 of 19
    lundylundy Posts: 4,466member
    Quote:

    All I know is, my job is done, now I do not have a need to ever connect these two machines again.



    OK, great. Just FYI, we forgot to tell you that FireWIre Target Disk Mode is the coolest way to do these kinds of transfers.

    Boot one machine with the "T" key held down, and it becomes a disk instead of a computer to the other machine (its screen will show a moving FireWire® logo). Snap a FireWire cable between them, and the normally-booted one can use the target one as a disk, and see its files.
  • Reply 9 of 19
    tilttilt Posts: 396member
    Thanks Lundy I knew about the target disk mode, but did not want to buy a firewire cable for what is essentially a one-time operation. After that the cable is pretty much useless to me



    Cheers
  • Reply 10 of 19
    chychchych Posts: 860member
    The reason it wasn't working earlier was because the airport express spawned an isolated network from the netgear; you would need to setup port forwarding or dmz host or router bridging or something else on the airport express to have it work right. Essentially the airport express firewalled the macbook from everything else; the macbook was on a different network from the mini.
  • Reply 11 of 19
    tilttilt Posts: 396member
    Ah, OK. Thanks Chych



    Cheers
  • Reply 12 of 19
    MarvinMarvin Posts: 14,209moderator
    Quote:
    Originally Posted by lundy


    Boot one machine with the "T" key held down, and it becomes a disk instead of a computer to the other machine (its screen will show a moving FireWire® logo). Snap a FireWire cable between them, and the normally-booted one can use the target one as a disk, and see its files.



    I'm not sure about target mode. I knew someone who tried that and ended up breaking 3 machines. Maybe he was doing something like this though:



    http://forums.macrumors.com/archive/.../t-167666.html
  • Reply 13 of 19
    vox barbaravox barbara Posts: 2,021member
    Quote:
    Originally Posted by tilt


    Thanks Lundy I knew about the target disk mode, but did not want to buy a firewire cable for what is essentially a one-time operation. After that the cable is pretty much useless to me



    Cheers



    Hey come on, a firewire cable belongs to every (computer) survival kit

    nowadays. imho, of course.
  • Reply 14 of 19
    tilttilt Posts: 396member
    Vox, care to elaborate?



    Cheers
  • Reply 15 of 19
    chris vchris v Posts: 460member
    If you're using an Airport Express with a router, you've got to uncheck the "Distribute IP addresses" check box in the Network tab of the Airport admin software. This lets the router assign the IP, and it just passes through the Airport. I couldn't network my Powerbook with ethernet-connected machines when that was turned on.
  • Reply 16 of 19
    tilttilt Posts: 396member
    Ah, thanks for the clarification Chris.
  • Reply 17 of 19
    vox barbaravox barbara Posts: 2,021member
    Quote:

    Hey come on, a firewire cable belongs to every (computer) survival kit

    nowadays. imho, of course.



    Quote:
    Originally Posted by tilt


    Vox, care to elaborate?



    Cheers



    I think there is everything said about the subject. Lundy gave you

    one example. And i am pretty much sure you will have the need

    to connect your Mac by a FW cable in target disk mode somewhere

    in the future, so you better be prepared. That's all.

    Not to mention, say, demonstration purposes.
  • Reply 18 of 19
    kukukuku Posts: 254member
    Maybe a bug, i've had that a few times. Network GUI is acting up. Usually needs time+ restart



    I get annoyed and just bypass it by using:



    Go->connect to server->type in IP address( get it through yor network control panel)
  • Reply 19 of 19
    vox barbaravox barbara Posts: 2,021member
    Quote:
    Originally Posted by Kuku


    Maybe a bug, i've had that a few times. Network GUI is acting up. Usually needs time+ restart



    I get annoyed and just bypass it by using:



    Go->connect to server->type in IP address( get it through yor network control panel)



    Yes, you have to mention, that you have to type in the IP adress manually only

    one time and store it as a favorite. Afterward you can connect to server quite

    easily that way, if the Network GUI fails to show up the network, which is quite

    rare (in my case)
Sign In or Register to comment.