G5 iMac won't stay asleep with HP printer hooked up

in Genius Bar edited January 2014
I just moved and recently pulled my HP Photosmart 1215 out of the mothballs to set it up. The thing is slow as a dog, but I can't afford a new printer right now, so I have to make due with it. Due to the configuration of my apartment, there's no good place for the printer by the computer, so I purchased off eBay an Ambicom wireless adapter to print wirelessly.

The thing works like a dream. I can't even tell there's not a wire, in terms of the time it takes to print. But there's a problem, which I doubt is related to the wireless adapter, but who knows: Everytime I put my computer to sleep, it wakes up 30 seconds (or so) later, displaying a message from "HP Communications" saying my system has lost communication with the printer.

I last used this printer with my old computer (a G3 iMac) that I never actually put to sleep because the display would always be a little weird upon waking from sleep. Back then I just used a "blank screen" screensaver to achieve the same effect. But using the same screensaver on my G5 iMac, the screen still has a "glow" to it that isn't good for sleeping (the computer is in the bedroom). Besides, it's obviously better for my machine if I put it to sleep every so often.

But this g**damn printer is hell-bent on not letting me do that.

I've already tried a few things: I found a script of some kind that, I was told, would make the HP Communications process quit upon going to sleep and start up upon wakeup. No dice, though. The computer woke up after 30 seconds of sleep, only this time didn't display a message at all. I also tried using a different driver, via Gugenprint, but that driver won't even let me print at all.

I also could always just stop the HP Communications process, but if I wanted to stop a specific process everytime I put it to sleep, I would have bought a Windows box. Besides, I don't know how to start that process up again.

And, yes, I know I should try it without the wireless adapter to see if that works. But even if it does, it does me no good, since I can't very well have the printer sitting in the middle of the bedroom floor (I doubt the girlfriend would approve). Any suggestions?


  • Reply 1 of 5
    I can tell you that if the USB ports on a sleeping Mac are active, the Mac will wake up. So it sounds like the printer is polling the Mac and keeping the Mac from sleeping.
  • Reply 2 of 5
    Originally Posted by CosmoNut

    I can tell you that if the USB ports on a sleeping Mac are active, the Mac will wake up. So it sounds like the printer is polling the Mac and keeping the Mac from sleeping.

    Thing is, it happens with the printer turned off, too. It's like the printer and the HP Communications program are constantly trying to talk to eachother.
  • Reply 3 of 5
    CosmoNut, your post indirectly solved my problem. I was approaching the problem in the wrong way: The problem was that since the two wireless adapters would keep talking to eachother, regardless of anything else, that would make the computer constantly wake up. The message from HP Communications was just a side effect of that.

    So after refining my search, I found out all I have to do is unplug the slave adapter from the back of my Mac, and everything works fine. So basically I'll just plug it in whenever I need to print something, and unplug it when I'm done.

  • Reply 4 of 5
    I had a similar problem when I installed a new CompUSA USB2 board. Then, I tried an Adaptec USB2 board. Same problem. However, the Adeptec instructions said that would happen.

    I disengaged my external hard drive from the USB port when I wasn't using it and - voila - my Mac would go to sleep.
  • Reply 5 of 5
    Um...glad I could help.
Sign In or Register to comment.