G5 iMac hard drive not working

in Genius Bar edited January 2014
Some strange problems started happening with trying to burn and copy some files on my computer. I went to restart, and it wouldn't boot up. I ran techtool off my Applecare disc and all of the tests passed until it got to the hard drive surface scan I think it was, and it had been running overnight and came up with something like 30 some errors. It wasn't even 1/4th the way through, so I hit skip just to see if everything would pass, and it didn't respond, I hit stop and still nothing. I tried rebooting again on the Techtool window is now burnt into the screen, and it still wont start up.

Booting on OSX install disc and running disc utility it recognizes the drive, but has no info for how much space is used/available and when trying to repair or verify the HD, it comes up with an error saying "there was an error upon exit" I think. I managed once to get it to boot up and I got some recordings off of it that I would be in big trouble if were lost, but while copying them to a firewire drive it would keep stopping and then copy a bit more, and pause for 10min and so on.

I'm pretty sure it's the hard drive. I've already had the logic board replaced a few months back, luckily I bought the extended warrantee. I have it in target disc mode now, but only the DVD is showing up, not the hard drive. I REALLY hope I can get some of my files back.

It's an iMac G5 2.0ghz ALS 120gb. Has this been a problem with anyone else?

UPDATE: the iMac hard drive showed up in target disc mode so hopefully I can get my files back


Sign In or Register to comment.