firewire drive not mounting

in Genius Bar edited January 2014
My Firewire drive was accidentally disconnected without unmounting, and now it's not being recognized.

I've tried DiskWarrior and now Data Rescue II, but neither program seems to be able to get past the first scan of the volume. Both apps seem to crash.

What else can I try?


  • Reply 1 of 5
    try turning your HD off, then log out your account, log back in and plug the HD back in.

    Hope that helps
  • Reply 2 of 5
    If you have the option to switch to USB2, I would. I have had nothing but trouble with firewire drives for the past coupla' years. Now, with USB2 on the same drives, no problems...
  • Reply 3 of 5
    Have you tried rebooting the computer? The firewire controller might be bonked and needs to be reset with a reboot.
  • Reply 4 of 5
    jbljbl Posts: 555member
    I had a similar problem recently. Someone suggested cleaning the system caches (Cocktail has an option for doing this). Fixed my problem. Actually, I think I also repaired the permissions at the same time, so I can't be sure which step actually fixed the problem.
  • Reply 5 of 5
    jasonfjjasonfj Posts: 564member
    Tried all those without luck. However, finally was able to recover the files using Data Rescue II, but it took a few tries to read the disk. I've now re-formatted the drive and copied the data back.

    I had't had any problems with the two portable firewire drives in the 3-4 years I've had them, guess I've been lucky until now.
Sign In or Register to comment.