Fastest video card....

Posted:
in Genius Bar edited January 2014
Anyone have an idea of what the best/fastest video card is that i can install on a g5 dual 2.0 (june 2003 with 8 memory slots)?

i bought an ati x800 xt which was DOA, then the RMA replacement kept freezing too. at this point im wondering if the card has problems on this computer or if i have just been crazy unlucky?

would this be the best card or would others suggest something else?

thanks

Comments

  • Reply 1 of 5
    MarvinMarvin Posts: 14,200moderator
    Did you make sure to get the Mac version of the card and not a generic PC one? Also, did you get the right kind of card for your machine e.g PCI-X or PCI-Express, there are different kinds of PCI slots.
  • Reply 2 of 5
    macflymacfly Posts: 256member
    Quote:
    Originally Posted by Marvin


    Did you make sure to get the Mac version of the card and not a generic PC one? Also, did you get the right kind of card for your machine e.g PCI-X or PCI-Express, there are different kinds of PCI slots.



    yes..it was a mac version and agp..which is what my dual 2.0 g5 has. the card actually worked well (the second one) when it worked, evidenced by beautiful rendering in halo....the problem was that it kept freezing randomly despite latest firmware and drivers. the freezes were impossible to predict and might be spaced apart by hours. go figure.

    they are going to send a third attempt soon.
  • Reply 3 of 5
    Maybe it is overheating... Does it only freeze when you are taxing it?



    Here's a great utility to monitor heat:



    http://www.bresink.com/osx/HardwareMonitor.html



    Also, you should confirm that the card's fan is running....



    Hope this helps.
  • Reply 4 of 5
    jbljbl Posts: 555member
    This is interesting. I had the same thing happen (same machine, same card). Apple actually replaced the mother board on this machine shortly before I put the x800 in, so I am not sure if it was the card or the new motherboard. I eventually put the stock 9600 back in and it still happened. So I took it back to Apple and they replaced the mother board. Now it works fine, so I was thinking it was the motherboard but could the x800 have fried something in there? I haven't had the nerve to put the X800 back in. Has anyone had better luck with this combination?
  • Reply 5 of 5
    macflymacfly Posts: 256member
    Quote:
    Originally Posted by JBL


    This is interesting. I had the same thing happen (same machine, same card). Apple actually replaced the mother board on this machine shortly before I put the x800 in, so I am not sure if it was the card or the new motherboard. I eventually put the stock 9600 back in and it still happened. So I took it back to Apple and they replaced the mother board. Now it works fine, so I was thinking it was the motherboard but could the x800 have fried something in there? I haven't had the nerve to put the X800 back in. Has anyone had better luck with this combination?



    dont think its the computer. the stock 9600 worked well before as well as after the x800.

    ati is shipping a third to me so hopefully this time will be the charm. i really hope it works. halo looks worlds better on the x800
Sign In or Register to comment.