15" Powerbook G4 won't find LaCie 250gb d2 on FW800, 400 or USB

in Genius Bar edited January 2014
My laptop:

15" Powerbook G4

1.67ghz processor

1gb memory

128mb vram

I believe the second to last Powerbook...I got it a couple months before they updated the screens to the higher rez and got the dual layer burners.

Hard Drive:

LaCie 250gb d2 Hard Drive with the Triple Interface, I typically use it with Firewire800

I bought both devices about a year and a few months ago. They've worked beautifully with no problems whatsoever. I'll admit, I unplugged the HD a few...errr...several times without ejecting it first. I go back and forth between work every day and it's easy to forget to wake my sleeping powerbook and eject the disc before I pack it up for work.

Anyway, I do a lot of audio and video projects. That's the sole purpose of this hard drive, storing audio and video projects. I have a hundred or so Logic Pro projects, a dozen Final Cut Pro projects. Some are personal but majority are projects I have with clients. Including a recent project I was hired to do that consisted of 2 hours of 3 camera angles and 14 tracks of audio. It's a big, super important project that I need the income from.

Unfortunately I do not have a recent back-up of these projects (yell at me later). If I were to lose this data I would be out several thousand dollars worth of income that I need. So any means required to recover this data, including the possibility of sending the hard drive off to get taken apart and recover data from the platters is something I will consider.

So onto the problem...

I had a session with a client, plugged in the hard drive...nothing happened. Didn't pop up on the desktop or in finder. Rebooted, came up for a sec, then said, couldn't access "Audio Disk" (what I named the drive). I turned the drive off, jiggled the firewire cable, turned it back on and everything worked fine.

Two days later, I plug everything in, and it doesn't come up in finder, or disk utility. The hard drive acts exactly how it would under normal circumstances. It spins up when plugged in, turns off automatically when I shut down the computer turns back on when it needs to. It simply isn't visible anywhere from the mac. I even tried playing around in terminal and listing the contents of the volume directory. Nothing happened.

I am also worried cause I download a lot of tv shows in iTunes and I'm down to about 4gb of space on my laptops hard drive. What will I do without TV?!?! (Trying to be humorous in a time of tragic fate)

So what can I do, what other information do I need to supply? Help would be appreciated as much as it is needed.

Thanks in advance...


  • Reply 1 of 1
    Forgot to mention I also tried plugging it in using a standard firewire cable and USB cable. I've also confirmed that the firewire 800 cable works fine. I tested it with my RME Fireface800 (sound device) and everything ran smoothly
Sign In or Register to comment.