My iMac G4 completely died after a powercut?

in Genius Bar edited January 2014
I have a iMac G4 800mhtz, 60gb HDD, 768 ram, running 10.4.8.

A couple of months ago the mac froze & I had to pull the plug (it wasn't responding to anything else). Afterwards I couldn't power it up (nothing was happening not even a light or a noise) after trawling the internet I tried to reset the PMU, this didn't seem to work I then replaced the fuse & it started (which seemed strange because the fuse was fine?).

Last week I had a power cut & the same thing has happened but now nothing seems to work, I've tried different wall sockets, resetting the PMU, changing the fuse. I don't know what to do now, If I take it to the apple reseller it be expensive & I'm planning on getting a new one after Christmas but I was hoping on not having to throw the other one away.

Sorry about the essay,

I just hope somebody can help.



  • Reply 1 of 4
    sounds like the power supply may have blown and would need replacing and or the logic board needs resetting. Both need to be done via an apple techincan at your local store.
  • Reply 2 of 4
    Yup. And welcome. Sorry your first post is for a problem like this.
  • Reply 3 of 4

    Yup. And welcome. Sorry your first post is for a problem like this.

    I'm a long time listener first time caller.
  • Reply 4 of 4
    I have a similar problem in that it wont turn on, except my iMac G4 1ghz was working perfectly ok when i shut it down 1 month ago to ship back to the UK. For the last 3 years it has travelled around with me to several locations while abroad, always packed properly in it original packaging. Ive just got back in the UK with it, opened it up and its dead, ive reset the PMU and tried a new power cable but nothing. As it didnt travel with me i have no idea if it was dropped etc but there was no damage to the packaging and has sat in a friends house until coming back by car.

    Is there anything while in transit that may cause this or Is there anything else i can try before taking it somewhere? ?as everywhere ive tried seems to be closed until new year anyway!

    Thanks in advance
Sign In or Register to comment.