Please help Corel Draw 11

in Mac Software edited January 2014
Hi, I just bought a macbook core 2 duo and having a problem installing corel draw 11. It says unexpected error and could not open.

I tried this software on my cousin's macbook the processor core duo and it works just fine.

Do you guys have a same problem like me?

Please help as I need this software for my work. Is there an additional application that I need to download?



  • Reply 1 of 6
    There is an update available (from March 2003).

    Corel dropped Corel Suite for the Mac in 2003, so the app really shows its age. You are almost better off installing Corel 12 in Parallels as it has a bunch of bug fixes they never updated to the Mac version.
  • Reply 2 of 6
    vp3vp3 Posts: 4member
    Thanks for the link. I downloaded this update and still doesnt work..I just dont understand why it does work on core duo processor but not core 2 duo processor. Am I missing something here?
  • Reply 3 of 6
    chuckerchucker Posts: 5,089member
    What does "doesn't work" mean, in particular?
  • Reply 4 of 6
    Have you tried copying the Corel-folder via target-mode from your friend's MB to yours? You could also burn it and copy it on your MB ...
  • Reply 5 of 6
    vp3vp3 Posts: 4member
    It says the application CorelDraw11 quit unexpectedly..I also did copy the corel-folder from my friend's mb to mine and still gave the same problem.

    I found the Solution on the internet (maybe).

    I will try it later...
  • Reply 6 of 6
    vp3vp3 Posts: 4member
    Great News!! It is working now. You just need to configure the printer...that's what you need to do.
Sign In or Register to comment.