FCP 3.0 Macbook Migration Problem System ID

Posted:
in Genius Bar edited January 2014
Did apples file migration from my old Ti Powerbook 550 to my new macbook pro c2d. Migration went ok but Final Cut Pro 3.0 won't open.



I get this error message:



Final Cut Pro requires a valid system ID which is either missing or invalid.

Please reinstall using the original CD that was used to install Final Cut Pro.



Okay so I reinstall from the install CD & I get the same exact error message.

(I deleted the original file migration install & then reinstalled from the Install CD)



Not sure what to try next.



Thanks for taking a look at this post.

Comments

  • Reply 1 of 3
    Uninstalled 1st from TI Powerbook & tried again after uninstalling all FCP3 files & reinstalling again.

    Same result.
  • Reply 2 of 3
    MarvinMarvin Posts: 14,182moderator
    You'll need to delete the registration file that ties your serial code to your hardware. Some high end apps do this.



    If you go into /Library/Application Support/ProApps/, there is (or should be) a file called Final Cut Studio System ID. If it's there, delete it.



    If it still gives the error, try reinstalling after deleting the file.
  • Reply 3 of 3
    Yeah I tried that & reinstalling, but doesnt work.



    I found out that FCP 3 does not install on Tiger 10.4.8



    I thought upgrade to FCP Studio, but nobody at Apple can tell me if upgrade will install without valid system install or does FCP Studio only require Serial Number to install upgrade.



    I have been on tech support now with 4 different guys and nobody can answer definitively.



    If I pay $699 for the upgrade, it can't be returned if it won't install.
Sign In or Register to comment.