Need help interpreting a crash log

Posted:
in Genius Bar edited January 2014
Hi, all,



My iBook (G3 900 Mhz, 648 RAM, 10.4.8 OS X) has been a real pain in the rear lately. It has been crashing--as in, I've got to hold down the power and reboot--almost daily. Initially, I had an occasional crash of this nature and that seemed related to Safari use. I decided in frustration to try a different browser, and it's still happening. It's even happened a couple of times when I was not even using a browser; I just had Mail open. I thought this might be a heat issue (I often hear the fan start up when I'm rebooting the computer), but still, this is obnoxious and needs to stop.



I've run Disk Utility, and it supposedly repaired permissions; I ran Disk Warrior, which couldn't do anything because I'd already run DU. Now I'm trying to decipher my crash logs and see what I can find in them of use in figuring out what to do next. I noticed the Firefox log is fairly consistent, so I'm going to paste part of it here. Can someone tell me what this means? (I wonder if it means I've got a bad font and if so, could that cause a whole-system lock-up?)





Date/Time: 2007-02-03 15:15:24.009 -0500

OS Version: 10.4.8 (Build 8L127)

Report Version: 4



Command: firefox-bin

Path: /Applications/Firefox.app/Contents/MacOS/firefox-bin

Parent: WindowServer [57]



Version: 2.0.0.1 (2.0.0.1)



PID: 197

Thread: 0



Exception: EXC_BAD_ACCESS (0x0001)

Code[0]: 0x0000000a

Code[1]: 0x0d7b0178





Thread 0 Crashed:

0 <<00000000>> \t0xffff88a4 __memcpy + 260 (cpu_capabilities.h:189)

1 ATS \t0x902a552c GetDataFontFragment + 120

2 ATS \t0x902a55c8 FTDataForkReadTableBytes(privateFontObjectRecord const*, sfntDirectoryEntry*, unsigned long, unsigned long, void*) + 120

3 ATS \t0x902c4050 _eFOReadTableBytes + 192

4 ATS \t0x902c3f60 _eFOGetFontTable + 124

5 ATS \t0x902c3ec0 FOGetFontTable + 112

6 com.apple.QD \t0x9177c0e8 FMGetFontTable + 76

7 org.mozilla.firefox \t0x006bb654 nsFontCleanupObserver::Observe(nsISupports*, char const*, unsigned short const*) + 300

8 org.mozilla.firefox \t0x006bbaec nsFontCleanupObserver::Observe(nsISupports*, char const*, unsigned short const*) + 1476

9 org.mozilla.firefox \t0x006bbc04 nsFontCleanupObserver::Observe(nsISupports*, char const*, unsigned short const*) + 1756

10 org.mozilla.firefox \t0x006bc3b0 nsMacUnicodeFontInfo::HasGlyphFor(unsigned short) + 64

11 org.mozilla.firefox \t0x0047db80 nsUnicodeRenderingToolkit::ATSUIFallbackGetDimensi ons(unsigned short const*, nsTextDimensions&, short, short, int, int, unsigned) + 504

12 org.mozilla.firefox \t0x0047fd00 nsUnicodeRenderingToolkit::GetTextSegmentDimension s(unsigned short const*, unsigned, short, nsUnicodeFontMappingMac&, nsTextDimensions&) + 860

13 org.mozilla.firefox \t0x00480878 nsUnicodeRenderingToolkit::GetTextDimensions(unsig ned short const*, unsigned, nsTextDimensions&, int*) + 352



Safari had a similar complaint, from its old crash files:



Exception: EXC_BAD_ACCESS (0x0001)

Codes: KERN_PROTECTION_FAILURE (0x0002) at 0x00000000



Any magic code-readers amongst us? Any insight would be appreciated.

Comments

  • Reply 1 of 3
    I'm not completely fluent in Log-ese, but it looks a lot like a font issue.



    Go to your root Library, to the Caches folder, and move the folder called

    com.apple.ATS

    to the Trash.



    Restart.



    Empty Trash.



    Restart again.
  • Reply 2 of 3
    Thanks for the input--unfortunately, although I followed the directions, it didn't work. My computer froze up again and gave the same error. Do you have any other ideas?
  • Reply 3 of 3
    MarvinMarvin Posts: 14,540moderator
    I hate fonts. People say font management in OS X is better than other systems and if so, I'd really hate to use other systems regularly. I don't understand why Font management is so hard for a system and I really don't see why it can crash the whole thing. The system should have a built-in method of only loading fonts that are needed on-screen at a given time and off-loading them when they aren't needed. If it detects a corrupt font, it should be able to recover from it just like how graphics programs can open corrupt JPEGs.



    One thing you can try is to boot while holding shift i.e safe boot. This seems to clean out all font caches in case you missed something. Then reboot normally once you have done this.
Sign In or Register to comment.