I think Nortons killed my Mac G3

Posted:
in Genius Bar edited January 2014
Way back sometime ago, I goofed in using Nortons System 2 on my Mac G3 imac 330.



At the time it was running (partitioned) for both Os x panther and os 9.2.



Since then my olde machine has been acting really odd...making all sorts of whining sounds.



So today, I finally removed the hard-drive and installed a brand spanking new seagate baracuda 80 gb drive, thinking it might just be the drive.



I put my Panther disk in, (don't have original disks that came with the machine) and booted up the machine.



At first all seemed to go well, I split the drive into to two...as per normal, and thats when the proverbial shit hit the fan.



The Panther Cd said neither drive could take the operating system. (the image of a big red X across each drive made that plain enough); but thinking it might be simply cured by rebooting, I did so, only to now find, that from that moment on the hard drive was unrecongnisable.



All I get is a grey screen followed by a mac file case, (not happy mac) and from there it hangs.



After a couple of fruitless attempts at rebooting off the CD, I took the Panther Cd out and tried to boot from OS 9.2 cd...



But....same deal...no hardrive recongnition at all



Oddly though, I put the stupid Nortons disk in and it recognised the hard drive that straight away.



Talk about frustrating.



I ran Nortons to check both partions and it said there we no problems....(like hell there ain't)



Next I tried to zap the pram...but option command P R doesn't work.



Next I tried "C" while running off both the OSX and OS 9.2 CDs. That didn't work either.



Next I tried using option apple ....no worky either.



Definitely, something stinks, because I am pretty sure Nortons has right royally screwed with the boot table.



I even tried pulling apart the machine and pressing the internal suda ( I think that's what its called) button that sits near the ram.



Trouble is, there are so many sure fire procedures and so called solutions on the net, and plenty that are completely contradictory...that I just don't know where to turn.



But as much as this problem is seriously this is driving me nutz..I don't want to dump my mac just yet.



Also , as far as I know, It's definitely not the motherboard, as the fault occurred straight after Nortons screwed up the system, and the pram battery is new. Also there is nothing wrong with the installed ram.



Other than suggesting I trash my beloved Mac forever... I don't know what else to do....



(seriously, I am getting so desperate, I am even resorting to dusting off my crapulent Windows box).



I'd appreciate your tried and true advice....



Thanks..



Aqua Fyre

Comments

  • Reply 1 of 1
    aquafireaquafire Posts: 2,758member
    Success.





    Turns out Nortons seriously screwed the firmware security settings.



    Cured it by booting Command Option O - F and resetting the Firmware codes.



    If anyone has the same problems, then my advice is to do as follows.



    Boot into Open Firmware by restarting your Mac and holding down Command-Option-O-F keys.



    To reset the security level of Open Firmware.



    There are 3 levels - 0 (or "none"), 1 (or "command"), and 2 ("full"). Level 0 is the factory default - a password is never asked for, no matter what function or snag keys (N, T, C, cmd-opt-O-F, etc.) are depressed. Level 1 ("command") is the most common Open Firmware password setting.



    This will enforce the restrictions as stated above, but not interfere with a normal startup. Level 2 ("full") is the most involved setting. It will apply the security restrictions found in level 1, and in addition, the Open Firmware password is required every time you start up or reboot the computer.



    To set the security level, enter one of the three strings, depending on what level of security you desire: type lines as follows within brackets.



    ( setenv security-mode none ) for level 0



    ( setenv security-mode command ) for level 1



    ( setenc security-mode full ) for level 2



    After setting that, enter ( reset-all )



    and hit enter key to restart the computer.



    Worked a treat..



    and BTW..



    Learnt my lesson...My Nortons Systems 2 disk is now in the trash can.
Sign In or Register to comment.