I think I killed my OSX partition...

in Genius Bar edited January 2014
The title says it all... And here's how it came to be.

I tried to open iTunes and after several bounces, a single error screen popped up, only it didn't say anything at all. It was only a warning sign with the iTunes icon on it and an OK button. At this point I joked to my roommate that this was even more vague than a Windows error message. I tried rebooting and at about the same time as IPv6 packet filtering is enabled, the message "disk0s2: 0xe0030005 (UNDEFINED)." pops up repeatedly.

That's my boot partition... Shit.

I DO have a backup though (I'm booted from it right now) and I know that I can fix this one way or another, I'm not really looking for advice unless it is a way to raise my partition from the dead. I have already tried to repair the volume to no avail, so I will just reformat it and clone my backup back to the drive. I just find it odd that the drive is still accessible yet it doesn't work all of a sudden.

I'm really just curious as to what exactly causes this error and why did it randomly pop up? I don't THINK I was doing anything at the time to destroy a partition...


  • Reply 1 of 2
    OK your boot partition maybe ok but have some errors in it which should be able to be fixed by booting from the Install CD/DVD and running disk utility from it. You could also try Disk Warrior 4.

    Lets know who you get on
  • Reply 2 of 2
    smaxsmax Posts: 360member
    I just said I had a backup partition that I booted from. I ran Disk Utility on that, no errors at all.

    No worries, I repartitioned the drive and cloned it back so all is good now... I was just wondering what would cause the error. Looking around, people seem to be linking it to weird problems like faulty chipsets and dying hard drives, but honestly I can't really believe either of that until I see some good evidence of it myself. I haven't gotten any read/write errors yet...
Sign In or Register to comment.