PB 15"/1.25GHz fails to boot (Many things tried already.)

in Genius Bar edited January 2014
I'm a pretty experienced Mac user but this one has me stumped: Powerbook G4, 15", 1.25 GHz (Firewire 800) Factory Config. except 2x after-market 512MB memory modules, dealer installed when new (appx 4 years old?) One owner machine (I'm the owner). Latest (released) OS installed, all updates current as of sometime in the last few days. Case never opened since bought. Machine never abused, dropped, banged, etc.

Sorry for the long post, but there's no point in folks guessing & suggesting things that have already been tried and I've been on this project all day.

Machine was running fine except web browser got hung up. Acted like possible DHCP assignment confusion (happens here now and then), so I rebooted & walked away. Came back later (15 or 20 min.?) and machine appeared to be off. Not so; hard drive was spinning. Touch power key and machine appears to "sleep". except no sleep light. Touch power again and it "wakes" but only the drive spins. Repeats as many times as you like; no difference.

Press power for longer time and it powers down. Start from "off" and HD spins, DVD drive looks for disk. NO CHIME at power on.

Force reboot, no change.

Reset pram, no change.

Reset PMU, no change.

Remove outer ram module, no change.

Replace inner ram module with other ram module (running just one still), no change.

Transpose ram modules from orig positions, machine boots in "open firmware" directly.

Open Firmware Says: "illegal instruction at %SRR0 394a0000 %SR1: 00081000" (etc.)

I type mac-boot to continue. ("bye" also works on a later attempt.) Now I have the no system folder icon flashing, so I put in a universal 10.4 boot DVD... The icon switches to a startup folder and the machine appears to hang (let it go 30 minutes or more once with no further changes, no drive-access sounds, etc.)

Multiple attempts, same result.

Force off & on, still no chime, DVD will not eject. Open Firmware continues to open with each attempt.

\t(Note that I am NOT forcing the open firmware manually [Cmd + opt + O + F]-- it just comes up that way at boot.)

Switch ram modules back to orig position. Nothing, just like before.

Try each module alone again, nothing.

Typing various key attempts, I note that f5 turns on the NUM LOCK LED and continues to toggle it at will.

\tNOT A TYPO, NUM LOCK IS F6, and F5 it turning the NUM LOCK lamp on & off under F6.

Everything else still the same as before.

Swap RAM modules again.

Now, as before, boot attempts open the Open Firmware dialogue.

Next in Open Firmware, I "reset-nvram" and "reset-all"

Both appear to work.

Proceed with "mac-boot"

Machine CHIMES, but still hangs, looking for startup folder (flashing question mark folder & startup disk icon as before).

Insert DVD. Machine hangs with startup folder icon showing steady (as before).

Force power off.

Press start. machine now CHIMES again, but all remains the same (including bizarre F5 / F6 issue).

Have also tried various combinations of above boot attempts with:

\tPower by battery only (supply unplugged)

\tPower by AC supply only (battery removed)

\tPower by AC supply with good (charged) battery installed.

Have checked (with bright light) and when screen is dark on boot attempts (as discussed) there is no sign of LCD info-- this is not a light failure, besides, the screen does come up in Open Firmware as discussed also...

I checked the drive last week with the apple utility and except for a few permissions (that were repaired) all showed fine.

Have also let machine sit unplugged with battery removed for a period of time today while doing the resetting per a suggestion made to me-- no help there.

Have observed (in Open Firmware) that date has reset to 19xx year so believe that reset commands have worked.

Was asked by one person if I normally drive an external monitor. No, I may have done that once, years ago, for a few minutes but I think that was actually a test with a different machine and certainly this is not typical or recent usage for this machine at all.

Flopping the ram and having it go or not go into open firmware might tend to point to a ram issue, but then it should work with one of the modules alone, so how could neither of them boot the machine alone? Did both modules suddenly fail at once on a warm boot? (Seems unlikely)

What about the drive? If the HD's system is trashed, the DVD should go. If the whole drive is trashed there's also a strong chance that the DVD would make it go, and besides, why did the CHIME go away and how about the sleep light?

Resetting the machine's settings cleared the CHIME problem but the thing still won't boot. The SLEEP LIGHT still does not work and the F6 LED still works only with the F5 Key even after the chime came back...

Dead logic board perhaps? If so, why would swapping two (apparently good?) ram modules change anything?

The ram, HD, and logic board issues are all pretty expensive. Get too far into this and buying a used machine is cheaper. If I had more ram I'd try that first (super-easy) but I have no extra ram around here in this "flavor"...

Any suggestions before I pull out the drive to see if it will open up elsewhere?

Sign In or Register to comment.