Macbook battery not recognized

Posted:
in Genius Bar edited January 2014
I have a 2.0ghz core duo Macbook, and basically the problem is that the battery indicator now has a black X in it, indicating that there is no battery. This first occurred after I had intentionally ran down the battery until the system went to sleep, as Apple recommends for battery maintainence once a month. I have tried resetting the PRAM and reseating the battery, but the indicator still just shows a black X. From what I've read on Apple's website, I should bring it to an Apple store at this point, but if this is avoidable somehow, that would help me out tremendously.

Comments

  • Reply 1 of 2
    smaxsmax Posts: 360member
    Take it in to a store, this seems to happen randomly on a few computers and should be covered under warranty.
  • Reply 2 of 2
    hi_qhi_q Posts: 31member
    If you havnt already, try using a little Isopropyl Alcohol on the contacts of the battery with a Q-Tip, or soft cotton swab.



    Also, check to make sure the RAM / Hard Drive Door is firmly seated and screwed in. If you have recently replaced your RAM or Hard Drive, sometimes non-secure screws will cause improper battery seating. When you seat a battery, dont be afraid to give it a little shove when you put the contact side in. You can use a bit of reasonable force on the battery , sliding the contacts in snugly. At work ( I work on MacBooks at Apple's Refurb facility ) I can solve this problem by the above mentioned trick with a good chance of success.



    And like stated above... if its under warranty, bring it to the nearest Apple Store opr call AppleCare. Let me know if any suggestions worked.
Sign In or Register to comment.