Flash Player won't install

in Mac Software edited January 2014
I'm having a weird problem. I have version 9,0,28,0 of Flash Player installed on my Intel Mac. But every time a new update comes out (the latest is 9,0,45,0) I download it and try to install it. The install always fails. It gets almost all the way through, then when it is trying to install "flashplayer.xpt" it suddenly stops and says I do not have enough access privileges to install. I am the administrator on this computer, the only account. I have repaired the permissions multiple times to no effect. I have uninstalled and attempted to reinstall with no better results. I tried creating a new account (admin) and installing. No luck.

Can anybody suggest a way I can fix this? I am definitely trying to install the Intel version of the Flash Player NOT the PowerPC one. Adobe has directed to me a Tech Note on their website. I followed the directions precisely and it still didn't fix the problem.




  • Reply 1 of 1
    rob05aurob05au Posts: 348member
    Make sure you don't have any web browsers open at the time and try this is may just help.

    Try this first run a check on your HD for errors via Disk Utility these can cause minor issues with some apps either not working correctly or not installing correctly.

    If errors boot from boot DVD and repair.

    Then try the trick below which has worked for me once or twice in the past.

    Remove and log out and back in and empty the trash

    HD/Libray/Internet Plug-Ins/Flash Player Enabler.plugin (If it is there)

    HD/Libray/Internet Plug-Ins/Flash Player.plugin

    HD/Libray/Internet Plug-Ins/flashplayer.xpt

    Removing these should allow the install to work fully.

    Remember to repair the permissions after it fully install as it screws some internet related permissions.

    I am on a PPC mac and I used the UB version and it works better than the PPC version for me.

    Lets know if it works.
Sign In or Register to comment.