C&C Zero Hour texture problem

in Mac Software edited January 2014
Hey - I have a question about Zero Hour, and Generals to a lesser extent. The issue is that many maps load with completely corrupted ground textures. Units, buildings, trees all look fine. HUD and GUI are fine. It's that the ground/landscape looks like an absolutely messed up patchwork of odd colors, lettering from the load screen, black and yellow bars-- a complete mess.

Here is someone else's screenshot I found showing the same problem: http://www.caphector.com/libwolf/img...apshot%201.jpg

They resolved it by moving the game folder from Applications to a different location, but mine isn't there to begin with (it's on an external HD).

This doesn't affect all maps-- some maps load just fine. Notably, a winter map with weather effects loads fine. But all the 1v1 forest and most of the desert maps seem to have this problem.

In Generals this only happened with a couple maps, so I just didn't play them (I play mainly skirmishes). But in Zero Hour the majority of maps load this way, and do so consistently. I tried a General vs. General challenge game, and its map loaded in this way too-- including the in-game in-engine cutscene.

I have an iBook G4 1ghz with 768 mb RAM and the 32mb Radeon 9200. OS X 10.4.6. I play with detail levels all low (though increasing texture resolution didn't fix the problem).

Both Generals and Zero Hour are version 1.0.0. I haven't updated because I was happy with performance, I don't play on line, and I didn't want to screw anything up further. However, if one of the patches addresses my problem I would happily update. I thought I might do the 10.4.9 update too, but wanted to ask first if it would make a difference because if it definitely won't (if there is some other known fix for this issue) I don't want to bother.

I've tried reinstalling both games.

Also, I made disk images that I play from so I don't need to carry around the DVDs.

If there's anything else you need to know to help, please ask! Thanks so much.


  • Reply 1 of 3
    cyloncylon Posts: 126member
    Haven't had your problem. Curious how you made your Disk image though. I tried it once with the Apple Disk Utility and couldn't get it to work.
  • Reply 2 of 3
    did you try installing on the PB's internal drive? If something changes when you do, it may that the game just doesnt handle being played through the USB / IEEE bus very well.

    Which one are you using, btw: Firewire or USB?
  • Reply 3 of 3
    nickgb3nickgb3 Posts: 32member
    USB. It's not an ideal situation. But Generals+ZH takes up so much space due to Aspyr's somewhat neolithic install process --I'm loath to give over three precious gigs on my main drive (which is only 40gb to begin with-- last time I don't spring for the largest built-in available).

    However, you may be on to something; I used to have it on a Firewire drive, but since moved the game to the USB because the USB harddrive is bus-powered and thus cuts down on another straggling cable tying down my iBook. But when I had it on the Firewire I had fewer of the texture problems-- though I also only had Generals, not ZH, at that point, so it's not quite a fair comparison.

    I guess I can bite the bullet, back up a bunch of iTunes, and just try it on the regular drive.

    Thanks for the suggestion!
Sign In or Register to comment.