LaCie hard drive mounts sporadically on my MacBook Pro but works fine on a MacBook

in macOS edited January 2014
I'm having a very strange problem. I was using my 500 GB D2 Quadra over firewire 800 to edit video in final cut, when everything crashed completely and I was forced to do a hard restart. Now, the lacie will only mount some of the time. Sometimes it just won't mount at all and I have to restart the computer. Sometimes it won't mount, yet it can be recognized by disk utility. Sometimes it seems to mount fine, but when I click on the drive to open it in the finder, finder says that it isn't responding. Sometimes after about five minutes it fixes itself, but sometimes it doesn't. And, sometimes it works fine. The oddest thing is that the problem is specific to my macbook pro. I've tried the drive with a macbook and it works with absolutely no problem. I've tried repairing my internal HD with disk utility and TechTool Deluxe. Neither found any errors. I have a full backup of my macbook pro from a few days ago, and I'm getting pretty close to wiping it and reverting. Any suggestions would be greatly appreciated.


  • Reply 1 of 2
    idaveidave Posts: 1,283member
    Sounds like a Firewire bus going bad. I had this problem intermittently on an old iMac and eventually I couldn't get any Firewire device to mount at all. I'd talk to Apple about warranty repair if I was you.
  • Reply 2 of 2
    yeah, thanks. turns out it was a bad firewire bus. It was freaking me out that it happened with both the firewire 400 and 800 ports.
Sign In or Register to comment.