in Genius Bar edited January 2014
It seems that the DHCP is causing an error for my mac on the network, is there a way to disable the DHCP and still have a wireless/wired network? I use a PPPoE, and if I do disable what will the side effects be?


  • Reply 1 of 8
    Wow, that's kind of an open-ended question! I'm thinking that you mean you would like to have a "static" ip address instead of the "dynamic" address usually provided by dhcp?

    You have to have ip addresses to have a network. You can leave the dhcp turned on, though, and still give your mac its own static address - however, I need more information to give you more help. For example:

    - Are you using a router of some sort? If so, which one?

    - Or, are you going straight through your dsl or cable modem?

    - What exactly are the error(s) you're getting on your mac that seem to be related to the dhcp or network in general?

    Give me some more scoop, and I'll see what scoop I can give you
  • Reply 2 of 8
    Originally Posted by mattc908 View Post

    It seems that the DHCP is causing an error for my mac on the network, is there a way to disable the DHCP and still have a wireless/wired network? I use a PPPoE, and if I do disable what will the side effects be?

    Oh, I see you've had some previous pleas for help out there! So, did you end up getting the suggested Linksys router? Or, are you still trying to go through another computer with the dsl modem attached? Or, ...?
  • Reply 3 of 8
    Okay sorry about the lame detail its a SRX400 Linksys (WRT54GX4), with an Embarq DSL (they ate sprint in our town) Its not an error, its just every 1-2hours itll pop me off the network from anywere 5sec-5mins, another person said that it was because of the DHCP on the router.
  • Reply 4 of 8
    Ah... thanks for the info - that helps. First (or, next, really question is: what security do you have set up on the router? WEP, WPA, WPA2, none? I ask this because, before doing anything with the DHCP, we want to rule out any possible security setup incompatibilities that can cause similar issues. So, if you set the router to be open, with no security, how is your connection?

    Oh, and one other question: do you know if the Embarq modem also has a router built in (what model is it)?
  • Reply 5 of 8
    I did get the suggested router, but it ended up being much slower than this one when all comps were on the network, each hogging quite a bit of the DL/UL bandwith. I had it set on WPA, than switched to WEP both cause the problem. No the modem from embarq does not have a router on it.
  • Reply 6 of 8
    Thanks for the info!

    I would first try turning off the security completely - just to rule out any WEP/WPA incompatibility. (I have a MacBook Pro, and had gotten a new Airport Extreme router, after which I had the same problem you're describing. I was using WPA2, and once I matched up the security settings it worked, but first it just kept connecting/disconnecting repeatedly.) Didn't you say in a previous post that you have other computers that are connecting properly, though? If this is the case, then a security mismatch could definitely be the culprit. That is what happened with my Mac - my Windows PCs were connecting perfectly, but I had to change the WPA2 settings on the Mac until I found the right combination where it would actually stay connected.

    If you turn the security off, and it still does it, then I would look at the DHCP. Here's the rub, though: there are just a few variables here that could be involved...

    - I don't have Embarq service, but I saw somewhere that their service is now DHCP. This is important because if your router is set to provide DHCP, but your Embarq service has their own router at their end that is providing DHCP, then the two would conflict. If this is the case, you should be able to set your router to 'bridge', and at least one computer should be able to connect to the internet with no problems. (I say "one" because you may need to call Embarq to see how to set up for multiple machines in this scenario.) If it's true that your other computers are working, however, then it's not likely that a DHCP conflict is the culprit, though I still wouldn't completely rule it out.

    - If your Embarq service isn't providing DHCP from their end, then you need the DHCP at your end so that each machine gets its own IP address. In this case, there are two things to consider: 1) check the length of time that the router is set to renew IP addresses. You could try setting this to the maximum amount of time possible to see if that helps. (Sometimes, when the router is renewing IP addresses, the computers may lose their connection - but this isn't a normal occurrence.) Again, though, if your other PCs are staying connected, then your Mac shouldn't be having a problem with this. 2) Try giving your Mac a "static" or "manual" IP address. You can do this in the Preferences. (Make sure you're changing settings for your Airport, of course.) Put in your router's address as the Gateway, and a mask of and set the Mac's IP address to be similar to the router's address - but outside of the DHCP range set in the router. For example, if your router is, and the DHCP range is 1 - 100, say, then set your Mac's IP to Doing this will keep the router from trying to change the Mac's IP address, so you can rule out IP renewal as the culprit.

    Let me know how it goes once you've read the above "book"
  • Reply 7 of 8
    What do you mean by: Match up the security? Just switch between WPA/WPA2/WEP untill it works out?
  • Reply 8 of 8
    No; sometimes I have to play with the settings for a specific security selection. For example, when you choose WPA or WPA2, both have an additional setting to choose that shows AES or TKIP. Typically, if you choose WPA, you would choose TKIP to go with it. If you choose WPA2, you would choose AES to go with it.

    My Airport Extreme Base Station (AEBS) shows WPA/WPA2 and then allows for both AES and TKIP at the same time (as though it'll just identify which the client is using). So what I meant by "match up the security" is to try different combinations - on your Mac - of WPA and either AES or TKIP or try WPA2 with either AES or TKIP, until you find one that works. As I experimented, mine suddenly started working and has worked fine since.

    I have a T-Mobile Dash that had the same connect/disconnect problem. On it, there were three options: WPA, WPA2, and WPA2-PSK. I had to select the WPA2-PSK with AES to get that one working. My Mac, the Dash, and my Windows PC each had to have a little bit different configuration to get it to work - all with the same router. Maybe if I understood the exact differences between the settings, I wouldn't have had any difficulty, but I don't. On my previous router (a NetGear), everything just worked with the same settings - WPA2 with AES. So, each router model may have its own interpretation of the setting combinations - I don't know. I just know that as I experimented with each combination, in each case I finally found one that gave me a good connection.

    Again, though, I only suggest taking the time to play with this if your Mac connects fine when there is no security turned on - 'cause if it still disconnects with no security, then it's more likely to be the DHCP.
Sign In or Register to comment.