PowerBook G4 Keyboard/Trackpad freeze on login

in Genius Bar edited January 2014
Hi there,

I am getting really strange system freezes on my work PowerBook G4 at the moment. I am due to hand it back so I was deleting my files off it and I decided to reinstall Mac OS to make sure I got rid of everything.

However, when I booted up from my Retail copy of Tiger I got a message graphic asking me to replace the batteries in my mouse. This was strange as I was using the trackpad. I assumed it must have been sidetrack which I had installed so I uninstalled that and tried again. This time it froze before doing anything, so I thought I would reinstall Tiger via target mode from another mac (iMac G5)

The installation went smoothly and I can get the volume to boot my G5 fine via target mode but when I try and boot the actual PowerBook G4 up it starts to log into OS X desktop but it only gets so far (before the clock appears) before freezing up - neither the keyboard or trackpad are responsive.

I've tried reseting the firmware and PRAM as well as the PMU but no luck. There is clearly something happening at log on which is preventing the system from working as both keyboard and mouse function fine whilst the system is loading. I unfortunately don't have the original disks for the machine so I can't do a hardware diagnostic.

Any ideas would be much appreciated as I don't want to hand it back in its current state.



  • Reply 1 of 2
    pevepeve Posts: 518member
    did you try to install over the existing os?

    or did you do a clean install?
  • Reply 2 of 2
    agiagi Posts: 13member
    Originally Posted by peve View Post

    did you try to install over the existing os?

    or did you do a clean install?

    It was a clean install - I used disk utility to wipe the drive over target mode from another mac.

    On further investigation it looks like there may be a problem installing on 17-inch 1.67GHz PowerBooks from a 10.4.0 install disk. I *cough* downloaded a 10.4.6 install disk to see if this would make I difference but I've been unable to get it to boot.

    My only other suggestion, which I will try when I get home is to update the install to 10.4.10 using the combo update whilst I am using the powerbook drive to boot another PPC mac via target mode and try again. I am almost sure it is a driver issue...
Sign In or Register to comment.