Need major computer help

in Genius Bar edited January 2014
Okay guys, this is a shot in the dark but I'm pretty much desperate at this point. I'm going to repost here what I posed on Apple's support boards.

Here's the deal, after installing Leopard I could not log into any of my accounts. When I log in, it goes to either a blue background or the Leopard background. Booted up Leopard disc to repair both startup disk and permissions to see if that was a problem. I also set a the firmware password. I then reinstalled Leopard. When I booted up, not only did the accounts not login as before, but when I tried to restart from the Leopard disk, it would not boot up from the DVD. Tried the tiger DVD that came with my iMac, didn't work either. I then tried to reset the PRAM, boot up in single user mode, and even tried starting up to firmware as a last resort, no startup commands work. I honestly don't know what else to try. If it helps at all, my master account was imported from my old ibook which shipped with 10.2.


  • Reply 1 of 6
    pevepeve Posts: 518member
    setting a firmware password disables the ability to boot from a system disk.

    if you still have all your data on your ibook i would:

    -disable the firmware password

    -boot from the leopard dvd

    -do a clean install

    -check if everything is running ok

    -import your user data from the ibook
  • Reply 2 of 6
    lundylundy Posts: 4,466member
    When you say "... tried starting up to firmware as a last resort, no startup commands work", do you mean that booting with command-option-o-f does not give you a firmware command line? If not, what DOES it give you?

    What is the "Leopard background?"

    Booting into the firmware should always work.

    If it does not, you could reset the firmware by removing one of the memory DIMMs and rebooting.
  • Reply 3 of 6
    pevepeve Posts: 518member
    removing the firmware password should work if you change the amound of ram (put in / take out ram), zap the pram a couple of times (reboot and hold alt+command+r+p keys 'till boot-chime sounds a couple of times).
  • Reply 4 of 6
    benroethigbenroethig Posts: 2,782member
    I was able to get everything sorted out through a pretty tedious process. Thank you for your suggestions everyone.
  • Reply 5 of 6
    pevepeve Posts: 518member
    ...and what did you do?
  • Reply 6 of 6
    benroethigbenroethig Posts: 2,782member
    Originally Posted by peve View Post

    ...and what did you do?

    Had to hold option key to boot up from the Leopard DVD. I then installed Leopard using the archive option. After installing I found that my admins had been changed to standard accounts. I then had to once again boot up from the Leopard disk and reset my root password to be able to restore my admin accounts. Lastly I had to go in after I was back up and running repair all my keychains.
Sign In or Register to comment.