Macs Speaking PeeCee (Samba In OSX Question)

Posted:
in macOS edited January 2014
Ok, so i have my g4 running osx 10.1.2 and i have my room mates gateway running windows me. i also have my friends computer accross the hallway running windows xp. i went through the home netowrking wizzard on both of them and set up a network w/ a 10baseT hub i had, the 2 pcs can see each other with no problems on the internet, however, when i go to connect to server in the finder and type smb://DIANE/YADDA to access my roommates shared folder, i get told that no file services are available at that URL. since the 2 pcs can talk with no problems, im assuming somthing is not configured correct on my machine. is there anything else in mac osx that i should configure before i can connect to the pcs?





(btw, i know the network is connected as we can connect in a tcp/ip network for games)

Comments

  • Reply 1 of 7
    neomacneomac Posts: 145member
    I really don't know, but I vaguely remember a similar thread.



    It is not enough to 'share folder' on the Wintel PCs, you also have to create a 'workgroup' on the PCs. I think you include that into the smb url as well.



    Don't know. Just a vague memory recall.
  • Reply 2 of 7
    ok, so i found out that NetBIOS has to be isntalled and/or activated on the peecees for it to work, how do i install it? im assuming its not installed because in the tcp/ip properties, its greyed out





    btw, the workgroup is mshome
  • Reply 3 of 7
    addisonaddison Posts: 1,185member
    [quote]Originally posted by ThunderPoit:

    <strong>Ok, so i have my g4 running osx 10.1.2 and i have my room mates gateway running windows me. i also have my friends computer accross the hallway running windows xp. i went through the home netowrking wizzard on both of them and set up a network w/ a 10baseT hub i had, the 2 pcs can see each other with no problems on the internet, however, when i go to connect to server in the finder and type smb://DIANE/YADDA to access my roommates shared folder, i get told that no file services are available at that URL. since the 2 pcs can talk with no problems, im assuming somthing is not configured correct on my machine. is there anything else in mac osx that i should configure before i can connect to the pcs?





    (btw, i know the network is connected as we can connect in a tcp/ip network for games)</strong><hr></blockquote>



    I think your format is wrong try:-

    smb://[email protected]/c



    Bob is your name

    Diane is the machine name

    c is the drive (Volume)



    You will be prompted for a workgroup and password. You can leave the workgroup blank you user name will appear in uppercase for some strange reason. You may or may not need a password depending on the security settings of the machine you are trying to connect to.
  • Reply 4 of 7
    dude, first of all, peecee is totally 90s... anyhow..



    no, you don't need netbios install on the windows machines for it to work (i don't)



    i have mine set up so that it's shared like this



    smb://[name of computer you're trying to connect to]/[name of the share of the computer you're trying to connect to]/



    so, something like:



    smb://MasterPo/Music/



    of course, i don't know how you picked your original names (yadda, etc) but with more info, maybe we can diagnose it better



    Ted
  • Reply 5 of 7
    ive tried the format smb://(computername)/(foldername) and it dosent work. i downloaded DAVE and it also dosent see the computers on the network, even after i enabled netbios over tcp/ip on the xp machine.



    btw, about the name yadda, i just quickly made a folder with a quick generic name and enabled sharing on it so i could try and get this working.
  • Reply 6 of 7
    well, real quick, it's actually the "share name" and not the "folder name" if the name of the sharing folder is multiple words or long, it'll be different (that's why i asked) anyhow, you can also try different workgroups.. also, you have a different workgroup (which i haven't seen before)



    so, perhaps try:

    smb://domainname_or_workgroupname;[email protected]/shared_rsrc



    so, for you, it might be:

    smb://mshome;[computername(one word)]/[computershare(one word)]



    i'm not sure if you'll need a username or not.



    i guess the workgroup defaults to workgroup (that's why i didn't need anything there)

    but anyhow, try that out and let me know if it works

    thanks



    Ted
  • Reply 7 of 7
    Funny enough, I had all of this working for me yesterday, using Samba to share files with Win2K boxes and smb:// in the connect to dialogue to connect. But today only Samba is working. They can connect to me, but when I use "Connect to..." I get the "No fileserver" error. I've managed to discern so far that the "Connect to..." Dialogue used mount_smbfs to mount volumes, and when I try to use it in the terminal as:



    mount_smbfs -U Christian -l 192.168.0.3 -W tokyo //blackbeauty/wwwroot /wwwroot



    I get the error message:



    mount_smbfs: can't set locale ''

    mount_smbfs: can't get server address `blackbeauty':

    Unknown host

    mount_smbfs: can't get server address: syserr = Network is down



    But connecting through smbclient that comes with Samba works just fine. No need to even specify an IP or workgroup. The line:



    smbclient //blackbeauty/wwwroot (password) -U Christian



    Connects like a charm.



    NetBios and NetBUI are enabled on the Win2K box. And all this worked yesterday.



    Any takers?
Sign In or Register to comment.