External Drives Slow to Mount

Posted:
in Genius Bar edited January 2014
I have two USB external drives, out of three, that are spotty on mounting. Once mounted, they're very dependable. These drives are in enclosures. One enclosure is both USB and FW, the other just USB. I've tried going both ways and it doesn't seem to make difference. I also tried connecting these to different USB an FW ports, that doesn't make a difference either. The only time that they show up is after waiting sometimes an hour and then they may not show at all until a reboot and then gamble on another hour.



This all started only after I installed Leo in Oct. I've allowed all updates since and never a remedy. Got one?



Edit in: Note: could it be an Oxford chipset problem? As I mentioned, I have three drives, the third I didn't discuss above because it always mounts. That enclosure is made by AcomData, which I'm unsure is Oxford either as with the others.



Tony

Comments

  • Reply 1 of 3
    What format are they? How old? last time since format?
  • Reply 2 of 3
    tony1tony1 Posts: 258member
    Quote:

    What format are they?



    Mac OS Extended Journaled



    Quote:

    How old?



    6 mos



    Quote:

    last time since format?



    6 mos



    One note on one of them, it has Tiger on it. Can't mount this on any of my machines. They're all running Leo. Don't know why this could be a problem since I mount a Lacie Porche with Tiger on it on an iMac about once a month. This drive is a copy taken from a previous MBP which of course was Intel just like the iMac. So maybe the question is can a drive having Tiger on it normally mount on a machine running Leo? Could there be a conflict? Do drives have to be reformatted under Leo to be read in Leo? Sounds like a new one to me, but then again it is a new OS.



    The other drive that was in question has been reformatted since my original post and is fine.
  • Reply 3 of 3
    What's happened to me in the past is Disk Utilility sees the device but doesn't mount the partition. In DU, hilight the partition and click the mount button.



    Or, I leave everything hooked up, hit the power switch on the drive box, wait 10 secs, flip it on, and the spin up phase kicks the drive in and it mounts.



    It's possible to take a store bought drive and format HFS on top of the Master Boot Record (used for Windows). But in doing so, can cause issues. Partition should be GUID for Intel Macs, APT for PPC.



    Can the 10.5 DVD see the drives with the Disk Utility (Menu: Utilities > Disk Utiliity)? Did you install Tiger from the DVD (should rule out MBR v. GUID thought) or from a disk image? Try running the verify permissions and verify disk from the DVD if the drives mount. If there's errors, try the repair commands to see if it can shake them out. Are these drives in a RAID? There was trouble with DU created RAIDs in older version of OSX with Leopard.
Sign In or Register to comment.