Connection drops, only appears after reboot

gongon
Posted:
in Genius Bar edited January 2014
I have this quite intermittent thing on my Macbook where the network connection drops, the 'book gives itself an IP address and stops trying. I tried renewing DHCP lease, setting Location to something that doesn't have Ethernet enabled and then back, setting the Ethernet connection to inactive and active while staying in the same Location, and yanking and reconnecting the Ethernet cable on both ends. I also tried another cable. None of this allowed the connection to happen between the computer and the router, but rebooting did. I hate rebooting. If I wanted to reboot, I'd have stuck with Windows. So now to find the problem...



Seems to me it's not the physical connection.



If it was a hardware problem in the Mac, it would be pretty subtle, since all those maneuvers didn't make it work and on the other hand it works perfectly after reboot.



My neighbor's Windows computer also using the same router does not get this same problem. I'm not completely exculpating the router based on this, after all compatibility takes two sides, but Mac seems 95% probable source of failure at this point.



Anyone knowledgeable about networks have an idea what I should be looking at, or what kinds of things I should try before rebooting next time this occurs to narrow down the problem? I'm comfortable messing with Terminal, just do not understand networking.



FYI, the router is out of my reach, all I have is a plug in the wall.

Comments

  • Reply 1 of 3
    MarvinMarvin Posts: 14,219moderator
    I've had this before when my ethernet network connection dropped too. Apple suggest either restarting or turning the ethernet on and off which you've done:



    http://docs.info.apple.com/article.html?artnum=106879



    I tend to restart as it's pretty quick but I don't like restarting either and if you have regular dropouts, it's not the best solution.



    It actually doesn't happen to me all the time after a dropout - it's quite rare. In fact, it can affect one computer on my router and not the other. For example, I've seen it where one computer on the router gets assigned 192.168... and the other gets 169... and can't connect. Once it's been restarted, it gets the 192.168... IP.
  • Reply 2 of 3
    kareliakarelia Posts: 525member
    Try taking the machine to another source, like to the local library, and see if you can hook up to one of their Ethernet locations for the time being, and that should tell you whether it's the fault of the MacBook or your router. Also, it wouldn't hurt to try connecting to AirPort, just to see if the problem is a software issue that might affect all connections, or an Ethernet-specific issue.
  • Reply 3 of 3
    gongon Posts: 2,437member
    Thanks guys. I had this happen a second time soon after. I'm now suspecting WoW has something to do with it, as I have only had it installed for two days now and both network outages have occurred while it's running. It's pretty insane if a game can somehow take out my whole networking until reboot, though... I don't see why an app would trespass in the OS on that level of things.



    I looked carefully before messing with anything on the second time, and System Preferences as well as ifconfig continued to show the correct IP and DNS settings (autofetched from the DHCP server on the router) even though no data was getting through. The ethernet cable also shows as connected. If those things are OK, what remains in the OS X structure that the data must get through but does not? Even if the game was doing this, it must be tweaking something in the OS that is restored upon reboot.
Sign In or Register to comment.