Trackpad not working on my iBook G3!

Posted:
in Current Mac Hardware edited January 2014
I have an iBook G3 600 MHz and today I changed the battery with another one I got from eBay.

Also I added 128 MB more .

But when I turned on the computer the trackpad didn't work!

Only the button worked.

Now I have placed a USB mouse but I really need to have the trackpad.

What is wrong and how can I fix it?

Comments

  • Reply 1 of 2
    ozzieboyozzieboy Posts: 15member
    So this happened when you installed RAM? Take out the RAM. Probabl a bad stick or non-certified for use with your machine. If that doesn't help, take out the new battery and plug in the machine...if it still doesn't work, you probably could benefit from resetting the PRAM. Google for direx. Also might want to check your sys prefs just to make sure the trackpad is activated. Sometimes messing with those will reset whatever is wrong. I'd also do a Utilities--Disk Utility--Repair Permissions.
  • Reply 2 of 2
    And make sure you didn't pull free the cable that connects the trackpad to the trackpad/button assembly. This is an "if all else fails", because you'll have to do some partial disassembly of the computer.
Sign In or Register to comment.