Leopard Firewall continuously prompts for iPhoto permission

in macOS edited January 2014
Can someone help me figure out why every time I launch iPhoto, the Leopard firewall prompts me to choose whether or not I want to allow or deny access for this application to accept incoming network connections...regardless of the fact that every single time, I choose 'Allow'? Here's a screenshot of the exact prompt that appears:

I've checked the Leopard firewall configuration in the 'Security' preference pane (which is obviously configured to "Set Access for Specific Services and Applications", and sure enough, iPhoto appears in the list with the 'Allow Incoming Connections' setting chosen....but it still asks me every time if I want to allow or deny connections, and I can't figure out how to make it stop asking??

Any suggestions would be greatly appreciated... Thanks!


  • Reply 1 of 3
    yamayama Posts: 427member
    I've experienced this with a few different apps after a new version of the app is installed.

    This is how I solve the problem:

    1) Quit iPhoto

    2) Open System Preferences and remove iPhoto from the list of allowed apps

    3) Relaunch iPhoto and click "Allow"

    After this it should be fine.
  • Reply 2 of 3
    m021478m021478 Posts: 71member
    Worked perfectly!!

    Thanks for the tip...
  • Reply 3 of 3
    mikep123mikep123 Posts: 31member
    Originally Posted by m021478 View Post

    Worked perfectly!!

    Thanks for the tip...

    I was actually getting this as well. Neither the previous tip or repairing permissions worked for me. I then deleted the iPhoto preference file (com.apple.iPhoto.plist in Library/Preferences) and that did the trick.

    Hope this helps someone.
Sign In or Register to comment.