Shutdown problem

in macOS edited January 2014

I'm a rather new Mac user (it's been about 6 months since I bought my new aluminum iMac).

Lately, I've been experiencing difficulties in shutting down my system, or even restarting it. I should probably note that I'm using 10.5.2

Sometimes, when I try to perform a system shutdown/restart, the OS gets to a point where only my desktop is shown but nothing happens (occasionally the beach ball keeps rolling, but not always).

At that point, (as far as I know) there's nothing I can do to restart/shutdown the system, besides pressing the "power" button for several seconds until the power goes down.

When similar things happened on my old XP machine, I would just use CTRL ALT DEL and force quit all applications - until shutdown succeeds. There was never a scenario where I needed to cut the power in order to get the system to shut down. On OS X when this situation occurs, the CMD ALT ESC combo doesn't seem to work.

Any suggestions?


  • Reply 1 of 4
    erunnoerunno Posts: 225member
    According to this site you can bring up the Force Quit window by pressing command + option + escape.
  • Reply 2 of 4
    lirandlirand Posts: 174member
    Thanks, but I specificaly mentioned that I tried it and it doensn't help...
  • Reply 3 of 4
    erunnoerunno Posts: 225member
    Originally Posted by lirand View Post

    Thanks, but I specificaly mentioned that I tried it and it doensn't help...

    Ah, sorry. I failed at reading comprehension. \
  • Reply 4 of 4
    backtomacbacktomac Posts: 4,579member
    Have you run disk utility to repair the disk and permissions?

    It may not be the source of your problem but I would rule it out.
Sign In or Register to comment.