Possible to turn off expose?

Posted:
in macOS edited January 2014
Is it possible to turn off expose? I keep accidently hitting the F11 etc. buttons and it's annoying the heck out of me. I never use it either.

Comments

  • Reply 1 of 4
    tarltarl Posts: 41member
    Use the Dashboard and Expose System Preference (I think the Leopard name is slightly different).



    Change the Keyboard shortcut to -. Then the computer will only beep when F11 is pressed. To avoid the beep, change the shortcut to shift-control-option-F11, or some other key combination that you will never hit by accident.



    I don't think there's any simple way to disable it completely. But if you never activate after a restart, it shouldn't use much RAM.
  • Reply 2 of 4
    yamayama Posts: 427member
    There's a whole bunch of apps which will let you turn the Dashboard off completely.



    You can also switch it off by running the following command in the Terminal:



    Code:


    defaults write com.apple.dashboard mcx-disabled -boolean YES







    Then, restart the Dock for changes to take effect:



    Code:


    killall Dock



  • Reply 3 of 4
    sc_marktsc_markt Posts: 1,393member
    Quote:
    Originally Posted by yama View Post


    There's a whole bunch of apps which will let you turn the Dashboard off completely.



    You can also switch it off by running the following command in the Terminal:



    Code:


    defaults write com.apple.dashboard mcx-disabled -boolean YES







    Then, restart the Dock for changes to take effect:



    Code:


    killall Dock





    Yama, thanks for the reply.
  • Reply 4 of 4
    sc_marktsc_markt Posts: 1,393member
    Quote:
    Originally Posted by tarl View Post


    Use the Dashboard and Expose System Preference (I think the Leopard name is slightly different).



    Change the Keyboard shortcut to -. Then the computer will only beep when F11 is pressed. To avoid the beep, change the shortcut to shift-control-option-F11, or some other key combination that you will never hit by accident.



    I don't think there's any simple way to disable it completely. But if you never activate after a restart, it shouldn't use much RAM.



    Thanks tarl.



    I saw those keyboard shortcuts but haven't tried them yet. I'll try your suggestion.
Sign In or Register to comment.