Problem w/ WD My Book-Formatting and Sharing

in Current Mac Hardware edited January 2014
I just purchased 2 Western Digital My Book Pro Edition 750GB Hard Drives. I hooked them both up to my Mac Pro, one to the standard Firewire 400, the other to Firewire 800. I have two MBP's so want to use each of them as a Time Machine Backup Drive. I ran into two problems though.

1. I was unable to share either hard drive. On each MBP Finder and Time Machine found a 2nd 1TB HD I have internally and am sharing but neither of these. I even went under sharing to set these up as shared drives. One different I noticed. If I right clicked on the Internal HD it had all the names mentioned that are sharing it. On the external drive it listed that it was shared but had no names mentioned or no place to select this.

2. I thought part of it may be that I need to format these two drives. I opened Disk Utility in OS 10.5.2 and chose to do this but ran into another problem. I can format each HD using MS-DOS (Fat) but it won't format in Mac OS Extended (Journaled) or Mac OS Extended. It does the same with each hard drive so I know it's likely not a problem with one drive. The error that it gives while trying to format as Mac OS Extended is "Disk Erase Failed. Disk Erase failed with the error: File system formatter failed." When I format using MS-DOS (Fat) it formats the drive and at the top in Disk Utility lists the same of the drive '698.6 GB WD" and underneath for one drive lists disk4s1 and the other lists disk5s1. I tried to select disk4s1 when I did a format but then got an error msg also saying "Volume Erase Failed. Volume Erase failed with the error: The underlying task reported failure on exit."

Am I leaving out a step or doing something wrong that's keeping me from formatting? Also, any reason I am unable to get these drives to share? In the past I had a WD My Book Pro 500GB on a Mac Mini with Leopard just after release and had no problem at all sharing it.
Sign In or Register to comment.